Illustrator has many problems (video)


#1

Here’s a little video I recorded showing Illustrator ruining a simple DXF file created with Fusion 360.

Basically all the video shows is Illustrator turning a smooth spline into a faceted approximation of what it should be. If you don’t need/want to see that, you can save yourself nine minutes by not watching it. :slight_smile:


Need something other than inkscape
Parametric Tab Test - Collaborations
#2

I am not 100% certain, but that may be a limit of the simplified DXF format, not specifically of Illustrator. Does it work better in Corel Draw? (paging @smcgathyfay )


#3

Post the file and I will check


#4

The issue did not present itself when the file was opened in Rhino if I watched the video correctly. That should tend to point toward AI vs Fusion 360 should it not?


#5

Entirely possible. I can’t watch with the sound on in the office so I am not sure what all was going on.

I would still be curious about Corel (or Inkscape for that matter).

There are a number of different ways to define a curve, so I wouldn’t be at all surprised if the 3D modeling programs understand each other but the 2D drawing program does not.


#6

That was good video @Hirudin.

:relaxed:


#7

The SVG and DXF that you uploaded into that other thread were also faceted, and I suspect it was done by your copy of Illustrator. It would be even more interesting if Illustrator is actually regressing instead of improving from version to version (but, frankly, I wouldn’t put it past Adobe to let that happen).

Yup, the file worked fine in Rhino. Maybe there’s some setting in Illustrator somewhere that makes it import DXFs correctly. Personally, I would have made it so that setting was visible while… you know… importing DXFs.

Here’s the exported DXF, in case anyone wants to try other software. FromFusion.dxf (4.3 KB)


#8

I’m going to go start capturing some screen shots of the settings I’m using @Hirudin, so we can have them to use to figure this out. (I don’t want to get sidetracked from finishing the tab testing though…one thing at a time or I’ll start to confuse myself.) :no_mouth:


#9

My corel doesn’t like your .dfx file…lol.


All I got was the unwanted lines…:unamused: which is odd because .dfx files usually open fine in Corel.

Although it opened correctly in the Sillhouette Studio…lol. No segments…smooth lines.


#10

Whoops - no it doesn’t. Completely ignore that first post above - F360 is either exporting curves as segments or AI interprets them that way.

Well that blows. (Had to turn off the stroke and zoom in to see them, but they are segments, and it’s a heck of a lot of additional nodes.)

Okay…gonna sleep on it…run some tests of my own.


#11

I tried to reproduce your issue using my older copy of Illustrator (CS5) to see if it was a version issue. I couldn’t even open the dxf file; I get the following error message:

My version of DxfDwg.aip is 15.0.2; I don’t know what the current version is. Adobe’s support site was no help at all. If there is an update to this file they have it cleverly hidden.

I did notice on Adobe’s support site the following:

Importing AutoCAD files

Note:

Illustrator will not open AutoCAD files saved in a version later than AutoCAD 2007.

AutoCAD files include both DXF and DWG formats. You can import AutoCAD files from version 2.5 through version 2007. During import, you can specify scale, unit mapping (custom unit for interpreting all the length data in the AutoCAD file), whether to scale lineweights, which layout to import, and whether to center the artwork.


#12

That’s funny! Frickin’ SolidWorks did the same thing. SolidWorks is kinda a piece of crap a lot of the time.


#13

No idea if this is relevant, but when learning to use vCarve/Aspire about a year ago at a makerspace, they made a big deal about setting all your software to use the same DXF version and they recommended R14. Seems to have worked with everything I’ve used since.


#14

I think that this is a limitation with MANY of the DXF exports I’ve seen. I’ve imported DXF files into Sketchup, and beziers are always segmented. Sketchup also does curves in segments, but at least you can control it until you “explode” the curve, or convert the curve into a polygon.

It’s annoying that more programs don’t handle Beziers correctly, if at all.


#15

For what it’s worth, the same issue exists in the even older CS4 version of AI.


#16

Well…I think i figured out a quick way to fix the segmenting in Illustrator. (Still haven’t taken the time to search through F360 to see if there’s a setting we can change.)

Select all of the curved paths (you can actually select everything, it doesn’t hurt linear constructs) then click on Object > Path > Simplify. Make sure the percentage is set to 100% on the slider.

If you do it a second time, it removes more nodes, but you start to get some very small wobbles in the lines, so you might want to stick with just doing it once.

It converts the straight segments to curves.


#17

If it hasn’t been done yet, I can try it on CC at work if you like.


#18

Inkscape gave me the same result as @smcgathyfay’s import to Corel


#19

DXF is limited to lines, not curves.


#20

It depends on the version of DXF and the support of the software’s import / export.

You can create a bezier drawing in Inkscape, save it as DXF, and then import it as a sketch retaining the bezier points into Fusion 360. I’ve done it myself, just now.

What people are discovering is that Illustrator’s export is translating the bezier into segmented line polygons, not into actual curves.

I’d suggest people try saving the Illustrator drawing as an Illustrator-native format (".AI" version 9 or newer?) that Inkscape can open. If Inkscape keeps the beziers, save it to DXF and import that into Fusion 360.