Illustrator SVG export turning my lines to objects?

Hey everybody, I recently re-installed Illustrator to the latest version and created a couple projects. Simple projects that would normally take a minute or two to cut.
I’ve been using my Glowforge for two years and Illustrator forever.

The first thing I noticed was the cut times were much higher than I expected. I watched the cutting and it cut everything twice, even though I know it was a single line cut. Also it wanted to assume it was an engrave instead of a cut.

My first thoughts were that Illustrator changed the way the app handles lines, or that the SVG export, which has changed a bit (more options) is somehow causing the line to thicken and become a shape.

Lastly after seeing some other posts, maybe it’s the update and not the files at all?

Any help or ideas would be appreciated.

I don’t have the most recent version of Illustrator, but I do remember seeing something about the latest version causing this. It might have been because of a setting (in Illustrator) that didn’t center the stroke by default if I remember correctly.

You might want to check the settings for the files to see if the stroke is centered.


Hey Jules,
Thanks, I went back to double check everything and I found the stroke was set to “inside” instead of centered. Techncially speaking that should not change anything since it’s just a visual change, and the actual line doesn’t change.

However when I can fire up the glowforge to test it I will and report back.

Thanks again!

1 Like

That’ll be the issue. Any stroke in current AI that isn’t set to center comes in as an object in the GFUI.


Thanks for clearing that up. I feel 100% better and my room won’t smell of burnt wood… as much.

1 Like

I’m so sorry to hear that you’ve hit this snag!

As @Jules said, this could be due to how the behavior outlined with AI. Could you let me know if the adjustment you made helped to clear up the trouble you were experiencing?

1 Like

I haven’t had a chance to make any actual cuts, however I set up a print job just to see the time it would take to cut, and the times were back to where I would expect them to be.

So changing the stroke to centered instead of inside was what fixed the file.


Awesome :slight_smile: I appreciate you updating us. I’m so glad to hear that this may have resolved the snag you were hitting. I’ll close this thread for now, but please don’t hesitate to reach out to us directly at if you run into any additional trouble. We’re here to help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.