Illustrator SVG isn't uploading to the glowforge


#1

Hello Glowforge forum,

I’m happy to be back since my last thread with an actual not-broken-in-shipment Glowforge that shipped out quickly so thank you to GF staff for that!

However now I have a new, and perhaps more dubious issue. After cutting out the founder’s ruler and making a tiny engrave of a drawing I had lying around I moved on to the third tutorial and made a quick design in illustrator to actually engrave, score, and cut out. However after saving the file as an .SVG and trying to upload it to the GF I have encountered countless “unexpected error” messages and no success in actually getting my file to appear.

Here is what I can diagnose about the issue thus far:

-it isn’t the contents of the file itself, I haven’t been able to get an .SVG with just a single path line to show up
-I was able to get an .SVG from inkscape to upload
-I’ve finagled with the illustrator settings on saving the svg file but have had no success

The adobe illustrator I have on this computer is outdated, CS2, which is the only anomaly I can assume might be causing an issue.

I’ve sent an email to support as well, if anyone has any ideas about what could be an issue please let me know. :frowning:


#2

When I save an SVG in Inkscape, I was told to save it as a ‘Plain SVG’ instead of ‘Inkscape SVG’. Does Illustrator have a way to save a standard / plain SVG?


#3

Illustrator saves a pretty clean SVG.

Inkscape has an Inkscape SVG and a Plain SVG. The Inkscape variety will throw in some stuff that is not SVG-compliant and can cause problems when uploading.

I’m not sure what the CS2 save dialog looks like. This is a good SVG export from CC18


#4

Hey is the site coming up for you? I was just using the app.gf but now it doesn’t come up and the main GF page also shows as down.


#5

Here’s a great resource for saving SVGs from Illustrator (and other apps):

CS2 is earlier than I use, but I think if you Save As… and select SVG, you’ll get a short version of this dialog:
AI_settings%20for%20SVG

I think there’s a “more options” button at the lower left that will reveal all these options.

HTH, and good luck!


#6

Have you tried dragging and dropping the file onto the Dashboard? (They had a little problem a while back with the Upload button - don’t know if that issue has been resolved yet.)


#7

Yeah I’ve tried dragging and dropping and lots of little variations with no success- I took the same illustrator file onto another computer with CS3 and the SVG I exported did work (good thing yay) so now I’m almost positive it has something to do with CS2. It’s not world ending but I have no idea what’s wrong with the SVG files CS2 makes. :confused:


#8

If you upload one here, someone can take a look. It would be best to zip it so the forum software doesn’t strip anything out.


#9

Thanks for letting me know about this.

Like others have suggested, would you mind sharing your file so I can take a look. If it’s more comfortable for you to email it to me at support@glowforge.com, that’s fine too.


#10

svg test.zip (564 Bytes)

Here is a test svg I made of just a circle path.


#11

Thank you @crimson_flygon. I’ll take a look and update the topic when I have more information.

If you save your design as an SVG instead of exporting, does that solve it?


#12

I have only made the SVG by saving, not exporting (I’ve tried both since out of experimentation with no success)


#13

Thanks for your reply.

We’re seeing this too and will keep looking into it. Since the newer version of Illustrator works, I recommend you use that version to create your designs.

I’m going to close this topic – please post a new one if you have any other questions.


#14