Image misaligned and prints drifting

Recently my Glowforge Pro has been having a couple of issues. First, the cuts are misaligned from the image in the interface. Sometimes it is misaligned to the left, other times to the right, sometimes on both the x and y axis. Not a ton, maybe half an inch. I ran the camera calibration and it did that successfully. It printed accurately for two or three prints, and then it is back to being misaligned. I also have tried to set the focal height to see if that would resolve the problem, but it did nothing.

The second issue, which I am sure is tied to the first, is that now it sometimes drifts during the middle of the print. So half of the print ends up being 1/16 of an inch off.

This is what I have done so far to trouble shoot it:

  1. Recalibrated the camera. Worked for a couple of prints, but the images is now misaligned again.
  2. Set material height to see if that would change anything. No difference.
  3. Checked the belts for debris and generally cleaned all the mechanics. Didn’t find anything. Still no difference.

I really need to get this figured out as I am approaching the Christmas rush and I can’t have this machine be down. :grimacing: Any suggestions beyond what I have already tried would be greatly appreciated! Thanks!

1 Like

Have you checked your belt tension?

2 Likes

from what I have seen reading the forums, belt tension and/or broken carriage wheels seem to be a common cause.

1 Like

No, I have not done that. I’ll try that this morning and see if it does anything. Thanks for the suggestion.

I loosened a bit and then reset the belt tension. The head definitely slides back and forth better now. Before it felt like it would randomly meet a little bit of resistance. I wonder if perhaps the belt had some torsion on it. However, the camera is still misaligned. I have attached a photo. This was after setting the material height and after working on the belt.

Looking at the cuts more closely, it is still drifting while cutting. You can see how the circle shifted and line doesn’t meet up where it should have closed. I am going to try and put more tension on the belt, but it seemed like it was all the way to the right when I tightened it.

1 Like

Great photos, thanks for posting. I don’t have any suggestion, but I’m paying close attention just in case I see this in the future.

Ok, I redid the tension on it again and printed the gift of good measure. Still looks dreadful. Also, one of them exhibited the symptom of drifting again during the cut process and didn’t cut all the way through. I made sure to push the pulley all the way over - so I don’t imagine I can get any additional tension on the belt. The head moves freely and when I press on the belt it looks like the example shown in the instructions. Any other suggestions on what may be causing this? I’m hoping a Glowforge technician can see something in the data or has additional solutions.

That ain’t right…

One part is I think a misunderstanding on how it works. When you use set focus it only sets for that one spot - so you’d align the top center GOGM - which looks like it lined up perfectly. In order to align the one to the right, you’d need to set focus on that spot - and then set focus a 3rd time on the left. Your overall camera image is only ever going to be correctly focused for one area.

As to the drifting - take your laser head off and see if one of your wheels has a crack. They had a slew of bad wheels recently and that kind of bump seems indicative.

Thanks. It still exhibits the same problem when I don’t manually set the focus but just use the medium maple plywood setting. But I didn’t realize that manually setting focus could lead to distortion of the image.

No, you are misunderstanding. The image you are seeing can only focus on one spot. So if you’re using the PG settings only the very center is focused on the image.

Using set focus means you can move the focus point to anywhere on a piece of material - so you can have it perfectly placed for multiple items - but only one will show as correctly positioned at each time. So you place the first one where you want it - then move your set focus. That first one will now show as “drifted” - but it hasn’t moved, and will still be exactly where you placed it when you cut. Only the image is drifted.

Before when I cut a sheet without setting the focus it would finish the print and the line work in the GUI would still line up with the actual cut lines. There wasn’t any shifting. But suddenly the exact same files are shifting where they weren’t before.

Ok. I might have the problem resolved. Fingers crossed. I ended up taking the carriage off and cleaning the belts with an electronics-safe cleaning solution, as well as really scrubbing the optics with Zeiss wipes. Then, with the belt off, I moved the pulley wheel all the way to the right and tightened it down. Then I reset the carriage and put the belt back on. I think I may not have been able to get the pulley over far enough with the belt still attached. First test print came out perfect (see screenshot). If the problem resurfaces I will post an update, but I’m hoping that this issue is resolved.

6 Likes

Hi @benjamin.george - Thank you for all the detail and photos, I’m glad to hear your troubleshooting looks like it may have resolved the issue.

Thanks to everyone who jumped in and offered assistance! I’m going to go ahead and leave this thread open just in case the issue does return. We’ll close the topic up if there’s no further need assistance in a few days.

1 Like