In middle of large multi step engrave. Got the dreaded "uploading" and grayed out everything again

Happened twice in the last day. Haven’t been able to actually finish an engrave because it keeps happening. Dan claimed they had this issue fixed, it’s clearly not.

1 Like

Anyone have any fix for this, or is my engrave donezo?

Try turning your Glowforge off. See if that will cause it to cancel the operation for you.

Also, see this post from @tim1724:

Thanks. Did all of these, still nothing. The problem is the little uploading in the corner wont let you run any operations of any kind. It’s happened to multiple people in the last month or so, and each time they (support) post about how they fixed a major issue and to post if it happens again. So I’m almost 100% sure this is on their end.

  • open another glowforge app tab/window with a different engrave. something simple. leave the other original tab open
  • hit print, wait for the glowforge button to glow.
  • cancel print
  • go back to the original window
  • error should be gone now
  • hit print again on the original design.

if the problem arises again, just follow the instructions again…


I got stuck on scanning last night running the same file for a third pass. The firs two ran fine. I was running them individually because choosing multiple passes exceeded the 3 hour limit.
This had only happened a couple of times in 7 months, but I had previously been able to break out of it by power cycling the machine. After 30 minutes of ‘scanning’ I gave up.

Thanks for that procedure. I think that ‘cancel’ needs work to be available and functional for each operation.

1 Like

So this process worked for you?

1 Like

I wonder why “scanning your material” ever locks up. Doesn’t it just move over the cut area, take a head camera shot of the red laser and go back to the park position?

1 Like

No, opening another tab and pushing another job through to the blink and cancelling didn’t occur to me. If it happens again I will heed your advice.

1 Like

As far as I know that’s the function, but seemingly the ball occasionally gets dropped somewhere in the communication. It’s clear they anticipated a need for the cancel button, it just isn’t functional being greyed out. Right now it’s like a placeholder for a feature that has yet to be implemented.


Possibly not related to your problem but there are a couple things the user should avoid.

  1. Never hit Print on the GFUI too quickly between jobs. If you do not wait for the Print button to flash once after the Ready indication you will get stuck in an endless Scanning. The big button will usually flash once about 14 seconds after the GFUI Ready indication. That indicates the unit is ready for another job. “Ready” only seems to tell the operator when it is safe to open the lid, not when it’s OK to start another print.

  2. Don’t try to cancel a normal Scanning process unless everything is hopelessly hung up. If you need to cancel a job before it prints then wait for the “Preparing Data” step. When I cancel during Scanning it boogers everything up. Cancelling during the “Preparing Data” step seems to work just fine.


I have had the same lesson in your #2.
So sometimes the cancel button is available during scanning, and being greyed out signals an error apparently.
It seems the ‘scanning’ phase has some loose ends software wise.


Totally going to try this!



Just happened to me again Jason, and that fix worked perfectly.

Hail Takitus! :tada:

Also, looks like when the cancel is greyed out the op is borked. 2 out of 2 times when it was locked up the cancel option is unavailable, but it is on a successful op.


thanks! this is a great workaround. had a very basic 2 cut file and due to some warp (stronger magnets on order) it did not cut through, did a resend to print… and yeah…the stuck on upload issue.
your steps fixed it.

1 Like

Thanks for posting about this. I’m so sorry to hear it happened again.

I’m taking a look at what’s going on.

The engrave areas looks like they extend past the current printable boundaries from that photo at the link. Could that be part pf the problem?

This kinda sums up how overwhelmed I am by your lifesaving suggestion…



It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email

1 Like