Introducing Snapmark (September 2018)


#1112

Something that might help @bonny and the team to track down the issues with it…

Score the snapmarks on a sheet of draftboard so that all the settings are correct, and take a screen shot.

Then on the screen, move the snapmarks and design (move them at the same time by selecting CTRL+A and shifting everything at once.)

Then Snap the marks back into place. Then Score them again. Take a screen shot of the second score results next to the first ones and post that. It helps them to see what’s going on.


#1113

Will definitely do that tomorrow morning! Thanks for the advice Jules! :wink:


#1114

We’re almost a year old on our machine… no email, no snapmarks… feeling hugely left out.


#1115

First one, snapmark scored.

After move it away and hitting snapmark button that’s the result of the snapping.

Then the Score result after the snapping!

Thanks! :slight_smile:

@bonny anything that you could help me with ? :slight_smile:

TIA


#1116

Is that actually snapping? Does it say that the design snapped, and you’re good to go? I forget the exact message, but it’s basically a success message.

@Jules can clarify maybe, but I don’t think you should be getting the focusing message on the Snapmarks, which is what is making me wonder if you’re getting the success message or not. But, it’s also been a while since I used Snapmarks (new machine isn’t enabled).


#1117

yes! it is Snapping but I can’t remember if gets any message, will check it out! but it’s definitely snapping!

Thanks


#1118

Me either :cry: would really love to have snap marks


#1119

So I was really excited to get snapmarks on my machine, however, nothing I do can get it to work. I just keep getting the no matching snapmarks found message. I’ve downloaded the file directly from GF website and tried that and Nada. I’ve taken the snapmarks into Inkscape and adjusted the size of the marks and that doesn’t work. I’ve powered everything off and waited a day, still nothing. I’ve tried cleaning the lenses or what I assume are all of the lenses. Anything I’m missing?


#1120

I’ve used Snapmarks only once…to do the first ‘test’ project with some pencils. So, I can’t help you a lot, but I do know that the Snapmarks have to be the exact size in which they were created by the GF team. Until someone more knowledgeable steps up here, you might try doing a search for posts that have been made by people having problems with it. Best of luck.


#1121

I’ve read through posts trying to figure it out. But I am taking the example svg file with no changes and still can’t get it to run. The original file can’t be wrong can it?


#1122

The original file has the wrong size snapmarks if you open it in Inkscape. I had to adjust them based on numbers I found on the forum.


#1123

I don’t use Inkscape, but I know that sizing has been a consistent issue for many. I know too, that the dpi needs to be correct (can’t remember now if it’s 72 or 96). I’m sure before too much longer, someone will give you some very good ideas about your problem.


#1124

I’ve tried both adjusting to the correct size in inkscape with both inches as well as millimeters. I’ve
also tried opening it straight from the download folder and into the Glowforge webpage. I might try with firefox next as I’ve been using chrome.


#1125

You might want to read through my notes too…I list a bunch of stuff that can keep the marks from reading.


#1126

Thanks for the notes Jules. There were a few things I changed, but still nothing. I’ll add the print I’m using and a photo of what my screen looks like but I’ve done the following:

  1. Changed it to Geometric bound boxing and saved it as a plain svg file (new to me!)

  2. Changed the size to exactly W0.332" x H0.405"

  3. Check to make sure the snapmark is on a single path similar to this persons issue

  4. I’ve input a thickness of .01 inches

  5. I’ve cut it on a white paper for high contrast

Here is a picture of my UI

Any help would be amazing.

Snaptestprint|20x12


#1127

Grab your calipers and actually measure the size of the marks that were scored on the paper, and measure the distance between them - point to point. See if it matches what’s in the file.

The only thing I can think of is that there might be some resizing going on in the Inkscape SVG export. Different versions of Inkscape can cause slight variances due to the export DPI used. (You want to export it at 96 DPI to keep sizes constant.)

You might also want to just try the original file that you downloaded…bring it into a workspace, score the marks, shift the design…then snap it back into place and score the marks again. Take a screenshot of the results with the rulers showing if it prints so they can see them.

If that isn’t it, Bonny might need to have the team take a look at it.


#1128

I got my calipers out this morning and everything seems spot on. I clicked export PNG and it says it is exporting at 96 DPI. I also tried downloading the original file without opening it up in inkscape. I even did it on a chromebook that doesn’t have inkscape so I know the file wasn’t coverted in any way. Still nothing. Time to take it to support? @bonny?


#1129

I’m wondering if the camera just can’t see the marks. I would try a couple of other things before throwing in the towel…first, try a print on a different material…something thicker like a draftboard scrap would be good if you have a piece lying around.

The other thing is to clean the lenses and the little windows on the side of the lens in the head…they might be dirty.


#1130

I cleaned all the lenses I could find and cut out the design on proofgrade draftboard with still the same error message. Thanks for all your help though!


#1131

Yeah, no problem. Sorry we couldn’t find it but I’m outa ideas. :neutral_face: