Is my GF BROKEN? Unwanted LINES running across my engrave


#1
  1. I assure there are NO lines running across my text.
    Its just a simple font text from illustrator, and created outlines of the text to engrave. Nothing fancy. Added some star themed artwork, again nothing fancy.

See photo 1.

1st attempt. Ran first print, and ruined a perfectly good PG material, these lines showed up for no reason, had to cancel print. (Photo 2)

2nd Attempt, I find another PG board, and put the artwork at a diagonal instead of horizontal. This time I paid attention to the red preview screen before hitting the print button and noticed the LINE shows up! Noticed how it only shows up going horizontal! Weird huh? Why is this happening?
(See photo 2)

y

3rd attempt, I power cycled the GF. Restarted the GFUI, reuploaded the image.
NO LINE in the red preview, cool. So I hit print.

And guess what, even though it did not show in the red preview before print like the photo above, the 3rd attempt was a failure, the LINE shows up on the engrave. Had to cancel print.
(See photo 3)

SO FRUSTRATED, I wasted 2 perfectly good PG materials and now I dont want to print anymore, scared anything will just have a line through it.

Any tips or suggestions guys?


Bamboo engrave for the first time. Why does it STINK?
#2

Could you share your file?

This looks like what I’ve experienced with open paths in my files. You may have shapes that look closed but actually are not fully connected and this is the software trying to close the shapes for you. In my experience, the lines don’t show up in the purple/teal bed preview (photo 1), but do in the red preview.


#3

Denise%20Puica%20Vu%20Hawaii%20Font

font text

and space themeSpace%20Theme%20Template


#4

thanks for taking a look and trying to help me out!
:pray:


#5

but notice the 2 files of the actual print, the lines show up ONLY horizontally and at different places of the engrave.


#6

I’m not seeing any obvious open paths here, but I’m certainly not very proficient at some of the finer-tuned troubleshooting people on this forum can offer. Hopefully someone else can weigh in on this with something more useful than just “rasterize it”.

You probably will want to do a union/merge/whatever on your text if you saw spots where your letters overlap not engraving as desired.

Good luck, and sorry I am not more help on this.


#7

Actually, for grunge fonts, that’s exactly the suggestion I give. :smile:

You will knock yourself out and potentially waste hours trying to clean up messy fonts…it’s not worth it. The engraving is excellent for rasterized images with the Glowforge…as long as you start with the text at the size you want to use, you will get vector quality with them. So why waste time?

(Always in favor of doing things the easiest way possible.)


#8

I’m self-taught with AI, so I only know what’s been useful to me. What’s your recommended way to rasterize? The few ways I’ve checked have seemed very low quality. (“Check the matrix” is an acceptable answer if you know it’s in there!)


#9

I don’t know that we wrote that up specifically…

Very easy though…

Select the objects to be rasterized (Not the cutlines though, unless you want them to show in there as well…you can just hide those, then unhide them later for cutting.) then click on Object > Rasterize and use the settings below:

Oh…and you do have to set the Embed Images dial when you save the SVG.


#10

David: Here is the link if you want access to the full seamless pattern. Only $5. :wink: As far as testing this, I would try the rastorization method, or grab a section of the vector file and print that while troubleshooting so that you don’t blow whole sections of a proofgrade sheet. Looking at the svg file, I don’t see any open paths, but if you use Illustrator, your can select all and then use the divide tool under pathfinder to separate everything. Then go back an fill appropriately. Rastorizing seems way easier.


#11

I don’t know what it looks like in AI but in Inkscape it is a real mess

I made the invisible lines black against the blue shapes and this was the result

The straight SVG of course looks like a black rectangle as it does in shared file


#12

That’s exactly like it looked when I brought it into V-carve pro. Quite the mess.


#13

I’m guessing (again, a guess) that it has something to do with self-intersecting paths. I only had a moment to glance at the file, but I’m guessing there are some in there for sure with the way the font is.


#14

Looks like there are no open paths at least. But agree the group on rasterizing this particular one for simplicity.


#15

When I had this issue I tracked it to a vector file that didn’t have open nodes, just some nodes that were overlapping/on top of each other. For whatever reason, the GF seemed to treat the overlapped nodes as open paths. The easiest solution is to just turn the image into a bitmap. (That would really help with the horribly complicated grunge text as well.) Your other option is to go through the file node by node looking for overlaps like I did. I’m not saying this is the cause of you issues, but it could be a very possible given the all the tiny vector bits in the file.


#16

This community rocks! Thanks everyone for all your valuable input. @Jules sent me a PM and said to rasterize it, though I did, and it turned out decent, not clearly as much detail as I hoped but it did the job.

Whats interesting about this “line” showing up is again, it shows up in different places of the finished print depending on how I position the artwork, but even if I flip the artwork (text) vertical, diagonal, or horizontal, that stupid line that shows up runs through my engrave always horizontally, and in different places. So from what I understand from everyones input is that the GFUI is some how taking the paths from the file and creating its on lines/paths?


#18

That’s the exact behavior I had in my file mentioned in the above link. There were technically no open paths, but the GF was confused by nodes on top of each other and treated them as open paths and created the lines.


#19

gremlins?
image


#20

I’m glad to hear that @Jules suggestion worked for you!

I’m going to close this thread but if you have any other questions please don’t hesitate to email support@glowforge.com or start a new thread.


closed #21