Just Trying Out Refurb Pro - Software Problems

My new refurb machine came yesterday and I’m trying to print. The machine sparkles with its “newness.” But when I try to setup my print with settings I want to use, the cloud software won’t let me do it. I click on the left side panel and the settings panel doesn’t appear. Rarely it appears briefly and then retracts. Some older designs from the catalog allow me to change settings, but others don’t. I have more success with proof grade material, but I’d like to try some
“laser rubber.” I have not been able to setup any of my designs, even those that worked on my other (returned) machine. Can anyone help me?

This is not a problem with the machine. This is a problem with the interface. Can you try a different browser? There have been some recent problems with Safari and an update to a virus protection program that some people use.

What browser are you using? What device (PC, Mac, iPad) are you using?

3 Likes

I am using Safari on an iMac. I will try Chrome. Thanks for the suggestion.

1 Like

Make sure your new machine is the one picked, as I did have an issue that I had both old and new machines still at the top for a bit.

1 Like

Thanks for the advice. Chrome worked, but I’m not as comfortable with it as I am with Safari. I’ll adapt.

2 Likes

The interface should be exactly the same if opened successfully in Chrome as Safari. There was a change to Safari that caused issues. It will get fixed eventually, so keep checking back to see if Safari works again.

5 Likes