Laser not firing - Help


I was cutting with my glowforge pro, and suddenly the laser head just kept moving but no laser was being fired. I noticed that the tube is not creating that usual light inside. This is the first time this has happened.

I tried the methods that people with the same issue have been told to try:

  1. Clean the laser head lens
  2. Check if anything is burnt in the laser head
  3. Configure the laser to “Full power”

But everything looks to be fine in the laser head. However, as i kept trying the methods described above, a yellow light appeared on my glowforge button, but just for a while, it’s not there anymore, however the laser still isn’t cutting.

When i first got my glowforge pro, the laser head was malfunctioning, so i got a replacement that i still keep around (it has issues focusing), i tried with that head and the laser it’s still not firing.

What could be the solution? Do i need to send my machine back for repairment? or do i need to buy a replacement? my machine was bought in march, 2021, so no warranty. However, this issue appeared out of nowhere, as i dont use my machine so much.


Here are some photos that i’ve seen that you usually ask for. Maybe you could check the log or give me some steps to check following actions.

1 Like

Captura de Pantalla 2022-09-28 a la(s) 16.13.40

I also ran the Gift of Good Measure at 14:48 Central Time, so you can check the logs. Nothing was cut, laser still not working and the button has a yellow light again.

Support does not participate here, this forum is just for community feedback. You need to send this info to support using the contact form.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.