Laser stopped working today

My laser stopped working. The print head is moving and going through the motions. Everything else seems to work except there is no light. It was working fine and half way through a job it just stopped etching. I cleaned the lens, restarted everything, I even took a look to see if the tube was broken or if there was fluid leaking from it but there was none. Tried printing a simple file but no luck. I tried submitting a 'request" but not sure it even went through because I didn’t get a confirmation. Any ideas on what is going on?

Most likely either a failed tube or power supply. The tube typically decays over time, so probably the latter. Regardless, the machine will need to be replaced.


Hopefully I’ll hear from tech-support soon

If you didn’t get the confirmation that a ticket was created, check your junk/spam folder. That’s the only way to be sure they have received your request.


Support will usually ask you to try the gift of good measure, a known file they use to evaluate the machine’s performance, and send them a picture of the results.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.