Laser turning off depending on orientation of imported design

Okay, I know this is going to sounds weird, but… I am working on some parts for tree ornaments that we’ll be having our teens and kids assemble at the library. It’s a design of my own making, so I won’t rule out the possibility that I’m the problem here, but when I load the .svg file into the glowforge, sometimes the laser disengages on parts of the design based on the orientation I place the piece to be cut at.

Initially, I thought it might be my SVG file - maybe I had done something wrong with designing it, and not connected all my paths. I’ve since checked that, and remade the file to ensure that they’re all there… and if I place the piece to be cut vertically in the all the lines get cut entirely. It’s only when I switch the piece’s orientation that some parts of it don’t have the laser turned on for - and it’s not always the same parts.

Pictures and svg are attached.
Snowflake Fern Design 1v2

It’s not the end of the world if there is no fix for things, but not being able to nest the pieces will greatly increase the amount of material we end up using for the program, and probably will mean we’ll have to reduce the number of participants we can have in it, when we run it in November (usually we’ll make somewhere between 200 and 300 ornaments in the first weekend after Thanksgiving).

Anyone have any thoughts?


I’m gonna reply with a hearty - OH THAT’S JUST WEIRD - and go download your art and see if it does the same for me.


I have seen this happen when the vector lines I am cutting are out of square. I suspect this is what is happening to you. I don’t know how to fix it though. It’s only happened once.

I am curious to see what others get with the same design but I suspect it will be the same results.

1 Like

I wonder if it has something to do with the transform/translate code in the SVG.

Actually, I wonder if it’s a bug in the SVG implementation. I knew this had popped up before so I searched…

Wayyyy back in the day, @chris1 did some experimenting:

However, he did test the translate function and it worked for him - at least in that test.

1 Like

Have you tried using a different file type? PDF, PNG.

1 Like

Good thought on that Eddie - I had not tried it before leaving work yesterday. So, I saved the design as a PDF and figured I’d give it a try.

After figuring out a work around to deal with the UI issues everyone is having right now (much larger than needed selection boxes seem to work - like 3 to 4 times the size of the artwork you’re positioning).

Unfortunately, that does not appear to fix the problem. Even using the PDF file, There will be a portion of the design where the laser is only applying power intermittently.

1 Like

Interesting. That could be what is happening.

Hello! @thayes I am so sorry about the print result issue you are running into with this design. I went ahead and tried to reproduce the results on my Glowforge and sure enough, those same lines are missing. I am going to further review this case with my specialists to make sure I don’t miss anything important for you. I will be getting back to you as soon as possible as soon as I learn more. Thank you!


Thank you so much for your patience @thayes. We’re seeing this across all of our tests as well.

As a next step, could you try saving the design as a plain SVG in Inkscape or Illustrator?

After saving the file, could you try printing the file on Proofgrade Material with Proofgrade settings and let us know how it goes?

Hi everyone

I want to thank everyone who took a look at things - I did try to making the file into a standard .svg, and continued to have no luck with the printing. While I didn’t have any proofgrade material on hand, I did use proofgrade settings on some basswood hardwood I had hanging about. The lines still kept not cutting.

I did figure out a workaround, however - I turned fill on for the entire design (and stroke off), then saved the file as a .png. Once I had done so, I imported the .png back into inkscape, and used the trace bitmap function to trace the design again. The resultant .svg file appears to work fine in the glowforge control UI, and prints all the lines - it is somewhat less crisp of a path than I had originally hoped for (a lot of the hexagon angles have rounded themselves out), but should be serviceable for our purposes.

My Guesses on what might have been going wrong?

Based on the deep dive of @jbmanning5 , and some personal logic (I am not a code guy, so this is going to be in layperson’s speak), I’m guessing that the issue was arising out of a compound issue created by how I had built the original svg, and how the glowforge UI handles users manipulating an svg - that some how, compounding transform commands are what was causing the issue.

Main reason that seems plausible is that there were issues with transform commands being supported before, and I had used transform commands to make large parts of that design (I made one arm, than duplicated it and used transforms to place the duplicates around the mid point of the back line). Something about images seemed to mess up occasional transforms in that post by @chris1 that @jbmanning5 found- if that issue was happening because of the transforms in the initial design, then it should have happened on the imported orientation. Since we’re only seeing it when the initial design is manipulated in some way (which it would make sense of the glowforge UI does by using some variation on the transform command),it seems possible that the issue has something to do with things being transformed more than once (ie, by me, and then by the UI).

Supporting that thought process, the traced png should have created an .svg with no transforms being used to define any portion of the design. That traced path can be freely manipulated and orientated in the glowforge UI, and results in a complete cut all the way around, without the laser ever varying it’s power output.

I’m not sure if that makes any sense at all, though. Maybe someone who does know code would have a better idea?

1 Like

I hate saying that I “like” these the best (since it’s giving you trouble) but it’s definitely an interesting problem.

I would put money on it being something in the transform elements but also don’t know enough to modify to thoroughly test and troubleshoot the hypothesis.


I’m so glad you were able to find a workaround @thayes! Thank you for including all of your troubleshooting steps, and thank you to all of our forum members for pitching in to help! This information is incredibly helpful, and I’ve surfaced this issue with another team of mine to further investigate this strange behavior.

In the meantime, I’m going to close this post. If you run into any other trouble, please start a new topic, or email us at We’re here to help!