Lid open error continues after strip replacement

I’ve read thru many of the posts regarding the lid open error and have checked with support, and am bwginning to feel hopeless for a fix. I made a very poor choice by teying to adjust the height of a burn by stacking some wood under my project, as it causwd the laser head to get jammed on the wood. After i removed the jam and closed the lid I got the lid open error. Support had me buy a new black strip for the back of the unit even though the jam was in the front. I bought the strip and installed it, but the error remained, so i tried reswating the strip and managed to damage it…grrr. i put the old strip back in and it still seems to be in working order, but I do still have the error. Can anyone tell me what other parts iishould be looking at that may be causing the error? Is their any other way to speak with support other than email. The process is very long between reaponses and very frustrating. At what point do thwy decide a diagnostic is in order? Please please help i am frustrated at the process to the point of tears almost.

I don’t think there’s anything else user-serviceable you can try for that error. The black lid cable is worth a try since you can swap it yourself and it’s a cheap part… when that fails, they’re likely going to say that your next option is to send the whole machine back for replacement. If you’re under warranty, that’ll be free, if not, expect a bill of around $1100 to get back up and running. Sorry there’s no good news here. Email is your best option for support.

3 Likes

They have given me the option that you mentioned and im taking. They said diagnostic showed electrical issue, so the strip was not the problem.

This fixed it for a recent machine I was working on. I think one of the components on the LED strip failed early. It was another case of higher then normal voltage at the sensor.

1 Like