Lid open --- tried everything --- please help

I’m at a loss. My machine is stuck on lid open. I have cleaned everything and the door and lid close completely. The lights aren’t on either which leads me to think it is somehow stuck on lid open. I have reset it numerous times, logged out, restarted the computer, combed through forum’s and have tried everything.

My machine is a pro. And I have tried to remove the tray, and pass through slot with no luck.

A few days ago this same thing happened after I made one print. I let it rest a few days, and when I turned it on, the lights came on. And it was able to do one more print. But now I am back to the same issue.

Can anyone help? Thanks so much!

Frustrating, I know. Here is a reference to an issue that might help.

Oh, Welcome to the forum!

1 Like

Another thing to check is that staple (interlock) in the back of the machine above the power switch. If not fully seated it will give a lid open message.


I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.