Machine Issues and I can't get help!

I just deleted an earlier suggestion because I saw in your photo that you have a Glowforge Pro.

That’s a different animal, given your description in the first post.

You are going to need to check something first, and if it’s being caused by that, then I can link you to instructions on how to fix it.

But bear with me for a minute…I have to go find it so I don’t have to take a bunch more photos…again. :smile:

ok! I was wondering where it went. It seems like a possible solution. The belts do feel like they are slightly different in tension.

First off you need to start with the gantry straight, once it is not straight all sorts of bad things can happen. To line it up, turn the machine completely off and then you can push each side all the way back and that will line it up. If it then gets skewed quickly push the pause button and then open the lid a bit to shut that cut down. At that point using your phone to take photos could be revealing (one person discovered an escaped hold down magnet!)

Give me a second…the Pro could have a different issue in addition…you have to check for that first…

1 Like

Okay, yes i do have the instructions written up already…please follow the instructions here to check for the sagging cable:

Jules it says that page does not exist or is private

Ooooops! I’m sorry…that was a response to a Private Message…I’ll copy out the contents here:

What was causing my gantry to jump out of alignment was a red cable that runs underneath the tube getting hung up on the fins for the heat sink. IT IS A HIGH VOLTAGE CABLE. Be damned sure that you unplug the machine before testing this.

You will need a few things to test this:

A small LED flashlight.
A cushion to kneel on. (optional)
If you have a lighted extending mirror that would be fantastic, if not, you’ll need to get a small mirror too.
Cell phone.
Masking tape.

Okay first:

  1. Unplug the machine from the outlet.
  2. Open the lid and lower the front drop down door.
  3. SLOWLY move the gantry (the laser arm) to about the mid point of the bed.
  4. Carefully place the lit flashlight on the left rail. Tape it down to keep it from shifting, it’s easy to knock it off.


  1. Looking down the left of the rail, underneath the gantry, you should see a reddish thick cable in the gap between the tank treads and the left wheel. Yours will likely be a lot cleaner than this one:

Take a picture of it with the camera if you can see it. (Hold the phone upside down.)

If there is too much slack in that cable, it will hang up on the fins of the heat sink when the unit homes to the back of the machine.


So what you are going to do is slowly, carefully, and GENTLY push the gantry towards the back, while keeping an eye on that red cable, and see if it binds on the fins of the heat sink. In order to view this, you might need to employ the mirror, and it helps to have someone hold the flashlight on the fins. You’ve got to get down at eye level to see it, so a lot of bending or kneeling comes into play.

If you see that it is catching on the fins, stop pushing it and pull it back forward again. Let me know so I can link you to the instructions for fixing it.

If the red cable clears the fins, it’s some other problem, and we can go back to tensioning the belts.

ok I don’t think it is a problem with the red wire hanging up on the fins. Can you repost the tension thing?

Yep! (Just something you needed to check before assuming the tensioning was going to fix it.) :smile:

Tried to work with the tension. Still having issues.

Third belt to check is the one underneath the laser arm. Instructions for that are here:

X axis (on the gantry) is not going to cause the whole thing to get skewed like that, it is completely independent. It’s one of the Y axis mechanisms.

Results of the GOGM print display some X-axis skew. That one needs to be checked too I think.

@bennieewhite, have you squared up the gantry for subsequent prints? Or did you just run the one and then stop when the laser arm wound up canted? And is it still getting canted after you square it?

Or make sure when you heard the “weird sound” that the head or gantry had not hit something. That blower shroud hangs down a lot and when it hits something we do not see it at that time. There are also other odd crumbs that could be interfering if they happen to fall in a bad place.

That damage might kick a stepper motor loose and that would need checking.

We resquare. Even when we turn it off and restart it, it starts going all over and sometimes comes off the track.

Based on what we are seeing when it moves I do not think it is that belt either. But we have tried to get the tension right on the Y axis belts and its still doing the same thing.

We have looked everywhere. Nothing was sticking up. Nothing on the tracks. We have only had the machine one month and this was our first project to push out for sale. We were cutting leather, the leather was still laying flat. We have never used any magnets in it.

Any chance you can share a video of this?

I have an opinion but watching what is happening would be useful.

(edit - ok, thread now closed. My opinion was that one of the steppers (or controllers) is faulty, and that it would have to be shipped out for repairs.)

1 Like

Thank you for reaching out about this yesterday in chat. Unfortunately, it looks like your unit is experiencing an issue that we can’t resolve remotely. I want you to have a reliable unit, so I’m recommending we replace this one. I’ve replied to your email about your next steps, so I’m going to close this thread. I’m so sorry about the bad news.