Magnet stuck to lens

I was trying to clean my lens but the magnet got stuck and left the tool! So the lens is now pushed in and I can’t seem to get it out.

I’ve tried a screw driver but it’s not strong enough and gets stuck at a certain point. All of this because my laser wasn’t cutting all the way through the material!

Send help!

1 Like

Get another neodymium magnet that fits inside that hole, tape it to a pencil thoroughly with masking tape (as in completely covered), gently insert it and pull the whole thing out. (Be careful not to scratch the lens and do not use a screwdriver.)


How’s she going to get anything in there with the lens in the way like that?


Just alongside one edge. The magnet in the head will connect to the neo magnet taped to the pencil head, and she can pull it out. The lens should come right out with it. (Neodymium magnets will jump across a desk to attach to each other…ask me how I know…and do NOT be nearby when they meet. It tends to send shrapnel flying.)


no…I’ve had some near misses myself! Ha ha! OK…I get it now…I figured there was some part of the equation I was missing.


Picture of the concept below, just in case it needs clarifying:

You want to cover the magnet to keep from scratching the lens.


Alternatively, you could pop the top off of the laser head, remove the mirror, and push from the top side of the lens. The lens is fragile, so I’d suggest doing something similar to what Jules mentioned by wrapping the end of whatever you use to push it with something soft, maybe even a Zeiss wipe.

Just another option in case you don’t have a spare magnet laying around.

If you do go this route, make sure there’s something to catch the lens, and that when putting the mirror back in, you put it back in the same orientation that you took it out. Good luck!


I am wondering why the blue tool would not do the job unless it was that which came apart and got stuck. if so then @raymondking32 's solution would seem best but I would make sure that whatever was pushing was both well-padded and the outer part those alcohol wipes so not to make any mark on the lens.

In normal cutting long narrow pieces of wood make up a large selection of one’s scrap and I would go there or a fresh bamboo skewer, but well padded.


thanks Jules that worked!!! but now my laser isn’t firing :frowning:

I tried using PG as well to see if that was the issue… didn’t work. any suggestions?

Did you install the lens upside down? Or maybe the ribbon cable isn’t installed all of the way on the head. When it does the focus step, check to see if there is a red dot on the material.


Yes, please double check to make sure that the lens is installed correctly in the head. The bowl shape needs to go up into the head. Instructions here:


Also double check the setting to make sure the power level didn’t revert to 1. It happens and can make it seem like it’s not firing.


everything is installed correctly. no red dot on the material either.

no red dot means check the cable. communication to the print head seems not to be happening.

1 Like

I tried re-connecting the cable again too and still nothing. Guess I need to email HQ. This seems to be a common problem. Scared because I only used it a few times in the past couple months - once I start my business this could be a big issue…

Thanks everyone for your help!

You’ve already opened a support ticket by posting here. Emailing won’t improve/hasten the response time.

got it thanks!

@audreywon1 I’m so sorry for our delayed response. I see you already emailed us about the trouble you’ve run into and we’re working on it there, so I’m going to close this topic.