My Dashboard doesn't load the proper designs into the interface

Long time lurker, user here. Third machine (don’t ask) when I attempted to cut the “Gift of Good Measure” the interface instead loaded a project from Sept last year, coincidentally the first thing I ever tried to create and cut. I’ve purged the caches, reloaded the screens, turned the machine off and on again. No change. Any Ideas?

There is a chance you may have deleted the info in the file and started another project by accident in the same file. you can revert the gogm back to original by pressing the 2 vertical dots on the top of the dashboard on the right side of the middle. click design details and then on the window that pops up on the right side click reset design. You can do this for any design purchased from glowforge


Try loading the metric version of the Gift of Good Measure. As stated above, since it is your first design, it is very possible you did it on the original Gift of Good Measure when you first got your first machine.


Now that is something that they should tell you first. Thanks, that fixed it

1 Like

I’m glad you resolved it! Thank you @primal_healer for your advice. I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!