Mysterious Enlargement of Template

Good morning, Glowforge folks. I’ve got a weird one going on here today.

I have a template for a perpetual calendar that I made in Inkscape and whenever I upload it, it changes size. In Inkscape, the diameter of the calendar is 6.998", but when I upload it to the interface, it’s suddenly 9". Strangely, the slots in the stand that the calendar fits into remain the correct width, but increase in length to match the tabs on the bottom of the calendar.

I didn’t notice this at first and went ahead and cut out the pieces. Everything fits and it looks great. It’s just too big.

If I scale the template back in the interface to the size I want, the slots change size (as one would expect).

I’m stumped. What is happening and how do I stop it? If anyone knows how to reverse this bizarre hoo-doo, please let me know! Thanks so much.

File > Document Properties

Change the units to inches in both places, and size the art board to 12"x20".

You can do this on every document or save it as your template for all new documents. Either way, this has resulted in things opening in the Glowforge app at the size I expected.

Alternatively save and use PDF files instead of SVG. PDF files contain physical dimensions, unlike SVG files where there’s some ambiguity as to what DPI to interpret everything at.

5 Likes

I have this happen often, even with my document settings with the artboard at 20x12. I’ve learned to measure them in the gui before cutting.

2 Likes

Thank you, @dan84. I didn’t think about the PDF option. I will try that.

This is the first time this has ever happened. Every other template I’ve used has uploaded with identical dimensions to the template file. The file and the interface are both in inches. This one just seems to want to be bigger! Too weird.

I will experiment with the PDF and see if that makes a difference.

I’m so sorry about the trouble you’ve experienced, but I see that you emailed us directly about the snag, and you’ve been able to resolve the behavior you were seeing. That’s great! I’ll close this thread for now, but please don’t hesitate to reach out to us in the future if you run into any more trouble. We’re here to help :slight_smile: