Need HELP from Corel experts for SVGs


#1

I’ve realized this issue is on my end with Corel Draw X7 so I’m moving this over here.

For the life of me I can’t figure out what is happening or what I inadvertently changed in my Corel settings to muck things up. I have had no issues with the hundred or files I’ve made in Corel, but for some reason saving as SVG is now severely compressing my bitmaps, regardless of the settings I’m using. I’m assuming and hoping there’s some setting that got changed elsewhere and I just can’t find.

FWIW old SVGs are importing fine with the bitmaps still intact. PNG and JPG also save fine with no compression; it’s only SVGs.

@jbmanning5 @smcgathyfay @Mike13 @Pwc-phil @shollg @jamesdhatch or any other Corel folks have an idea? (Sorry to spam you all. I’ve gotten so desperate that I was going to try reinstalling Corel, but I’ve torn my house apart and damned if I can find my CDs. :frowning: )

I saved the image on the left as jpg and then a SVG and imported them back into Corel. Here’s the result.

Here are the settings I’m using (and always have).


#2

I’d avoid a full reinstall for the moment (which doesn’t seem to be an option since you are searching for the discs) and try just resetting Corel back to its default settings.

I’m not sure if Method 1 makes a backup of your preferences; if you use method 2, you’ll have your original settings backed up.


#3

I’ve never had much luck importing svgs into Corel…I’ve just been opening them up in Illustrator and saving them as .ai then import into Corel.


#4

I’ve always had very good luck with Corel SVG and it’s something very recent that changed. Never got PDFs to work well though.


#5

Oh wow…exact opposite…I do pdfs all the time…lol. I’m using X6 on my computer connected to my lasers…I’ll try in X8 on my other computer on Monday…


#6

The Corel 2017 SVG is slightly different.

When we did have issues with SVG though, the PDF still worked.

If not fixed in a bit I will load the old x4 corel and see if it varies from what you showed.


#7

This topic was automatically closed after 32 days. New replies are no longer allowed.