Need Help with Premium Issues

I’m having an issue with my Premium subscription. When I try to engage the Fonts a Solid white
Box covers the area and I am unable to access any of the Fonts. I have Contacted Tech at Glowforge
and I have spoken with them 3 times. they sent an email stating the issue was fixed, but the email was for a different issue and didn’t pertain to my issue. I have Troubleshooted by trying different programs and I still have the same outcome. Has anyone else had this issue? Can anyone help mw figure out why this is happening?

Do you have some text selected on the screen? A screenshot would help.

1 Like

screenshot attached.

This has happened to a few users recently and seems connected to a browser update. Try opening the app in a different browser.


yes, i have text selected and when I click on the premium the fonts are covered by the white square

Do you have any favorite fonts?
you might try down the list


I have tried 4

I have tried 4 different browsers


What he’s referring to is that currently your screenshot shows you in the “Your Favorites” section - if you haven’t picked any favorites then it would be blank. Can you show us what it looks like when you click on any other section?

Usually it would say “No Matches”, so I would lean toward you’ve got some sort of blocker set as a default. Do you get the same issue when you go into incognito mode with all add-ons disabled (each browser has a slightly different version of that).

For example, in Firefox & Chrome you can see your add-ons in the upper right corner:
and if you go into Incognito you’ll see that none are loading:


It doesn’t allow me to pick any favorites. GF did inform me yesterday that they are now receiving multiple calls on this very issue and has stated that they have a team working on it, but is unsure as to how long it could take to resolve the issue.


Boo! but also Yay :smiley:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.