New Machine Stuck on "Connect Your Glowforge to WiFi"

Hi everyone! Looking for some expert input. I just got a refurbished version of the Glowforge to replace the other one that had been glitching but I cannot seem to complete setup. The screen stops at “Connect Your Glowforge to Wifi” after I sign into my WiFi network. I have attached the screenshot of the issue and would be greatly appreciative of any direction. Thank you in advance!

Have you connected to the glowforge wifi with your phone/pc/tablet? Also, make sure that if you are using a device with cell service that you put it in airplane mode or turn off cellular data before doing so or it will not work.


THANK YOUUUU! It worked! :smiley:

1 Like

Oh boy…new problem. Even after it set up and connected to the wifi it still says my machine is offline and the image it shows when I try to upload an image is one that does not even look like what the bed of the laser is like.

My crumb tray is in with maple to cut and this is the image that appears on my computer.

Does not even provide a true reflection of what is in the bed of my machine

and this shows up…

I have no idea what I’m looking at with that… It doesn’t look like anything I’ve ever seen.

Try powering it off. Leave it sit for a few minutes. Make sure nothing is in the bed (no materials). Make sure the lid and front door are firmly closed. Then power it on again. Let it go through centering and calibration and once that is done and the head is back in the home position (upper left corner), go to your browser and open the glowforge app and see what it does.

In the upper right-hand corner of the screen, make sure you have the correct machine selected. You might be trying to connect to your old one --?


I have it selected and it is offline :confused:

1 Like

From way back when I’m pretty sure that’s the last image they took in the factory QA process.

There’s someone else having a similar new machine/shows offline issue. It may require staff, but in the meantime I’d definitely clear cache/use a new browser (or you phone) and connect to WiFi again to see if you can shake it loose.


I tried all of that and no luck so far…hoping to hear back from tech support soon

1 Like

I’m so sorry for the continued problems! I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.

If you run into any other trouble, feel free to start a new thread.