No bed image and/or Incomplete Image Upload


#1

I’m trying to upload a design, but either the bed image isn’t showing at all or only part of the design is uploading (and I think the glowforge app itself is freezing since I can’t select or more the partial design when it is there).

It’s also taking forever for the design to even show, if it ever does.

I’ve tried resizing it via illustrator, but I’m still having the same problem. Right now it’s pretty tiny (about 2x1"), unless there’s some other to “resize” a design?

Things I’ve done already to try to resolve this:

  • Restarted my computer
  • I’m using Chrome (current version: 67.0.3396.87)
  • Turned the machine off and on several times (with enough time for it to really shut down).

Any other suggestions?


#2

Complexity for the app usually relates more to the number of nodes to process rather than the dimensions of the object. The dimensions come in to play when it comes to raster engrave, but that won’t cause you problems until you hit the print button (not on upload).

Are you able/willing to share the design file? There are some pretty savvy Illustrator users around here that’d likely be able to give you a workaround for the problem you’re seeing.

By the way, what browser and version are you using? Edit: nevermind, I see you said latest Chrome.


#3

Using Chrome and it’s up to date. Not sure how to check the exact version. Here’s the file. :slight_smile:


#4

That looks like a file you’d want to engrave only (not score or cut), right? In your shoes, I’d rasterize it into a PNG of sufficient resolution and upload that.

You could also embed that PNG in an SVG so that you can get accurate placement relative to other design elements. There’s a way to rasterize just a part of an illustrator design in Illustrator, but since I’m an Inkscape guy I’m not exactly sure where to point you.


#5

Ok, I’ll try that. I have a feeling that MAYBE this could be a “cookie” issue too. Sometimes when I try to open a file, it opens an old one from days ago. Or maybe that’s a totally unrelated issue. Lol.


#6

And yes, it’s an engrave-only file.


#7

Just an update… I had to clear cookies on my browser in order for the updated PNG file to work. The original vector file still wont work. It seems to make the GF app crash.


#8

Same thing happens for me when uploading your file to the GFUI. Buttons around the app still work, but I’m unable to select and/or drag and drop the design around. It’s stuck.

I’ve created an svg with an embedded PNG rasterized at 540 dpi and about 11" wide. You could do it in pieces to run it as separate jobs, but at that size, it runs about 21 minutes for SD Graphic Engrave:

puppies-raster.zip (373.0 KB)


#9

Thank you! I tried another file (attached) and it still did the same thing. :frowning:


#10

I dunno what it is about the above file, but my GUI hates it too. I could bring it in, but only parts of it showed up and I couldn’t select it or manipulate it at all. It then froze up the GUI and I couldn’t get a bed image either.

I opened the file in Coredraw, made a copy and converted the copy to a bitmap just to see what they’d both do. Saved the vector and bitmap version in a single SVG and it loaded and processed fine. :woman_shrugging:

EDITED TO Add: I forgot, I also ungrouped the vector image and welded all the pieces together so it was one pieces and not 50+. The original file with all the pieces still worked when I re-saved as SVG in Corel, but it was much more cumbersome. See last pic.

sddf


#11

The same exact thing has been happening to me today as I’m trying to engrave a map on wood today. Just black background and can’t see the wood or design at all, it’s also happening on all my old designs. annoying :/.


#12

I cleared something like that up by really quitting Chrome (took right clicking on the tray icon, restarting the computer would have also worked) and doing a hard refresh on app.glowforge.com. I think something was wedged in the JavaScript application’s state.


#13

Thanks for letting us know about this. We’re seeing this, too, and we’re looking into it now. In the meantime, I was able to upload the files and avoid these issues with a few workaround steps. Could you please try the following?

  1. Close your web browser, then reopen it.

  2. Open the two files in Inkscape.

  3. Save each file as a Plain SVG.

  4. From your Glowforge app Dashboard, delete the versions of these designs that were giving you trouble before.

  5. Upload the design files you saved in step 3.

Let me know how it goes, and if you run into any other unexpected behavior.

Thanks!


#14

105 objects and 6,613 nodes in the original file. If you select them all and combine, that would help some as @kittski mentioned. She has lots of experiences with dogs, both the furry kind and the vector kind!


#15

@vee Just FYI I had it happen again tonight at 7:05ish.
I had been working on the GUI and everything was fine. I then let is sit for a bout 20 minutes or so. When I went back for a final adjustment of my file in the GUI, the screen went blank. I had to reopen my Firefox bower a couple of times and reloaded things from the home screen and about the third or fourth try, I got the screen back.

.


#16

Not sure if you’re working from a desktop or a laptop… but I don’t think the GFUI is very fond of anything that falls asleep on it. It seems to hate when my laptop falls asleep (on battery power) with it open. I usually have to do a page refresh to make it go normal/update status/etc.


#17

Thanks for letting me know, @kittski. I’ll pass this along to the team as well. We’re looking into it now, and I apologize that I don’t have any further details to share at this time.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. @julesmakesthings, if you still need help with this please either start a new thread or email support@glowforge.com.


#18