No Design Library

Good Morning! After two successful prints this morning, the app went to a blank white page. I can’t access it either from my computer or my phone. Even the main website is just a giant black and white Glowforge logo. The status page says all systems are operational…Is there a system outage or is this an error on my part? Thanks as always for your time!

1 Like

I have the same problem…

Same here. I hope it comes up soon!

Thank you for responding. Me, too!

Thank you for responding…For once it’s not me! :slight_smile:

I just tried connecting and had no trouble. Make sure it says in the address bar.

Same here.

Same here, tried to load on three different devices, three different internet connections (one on a different continent) and with Chrome, Edge and Internet Explorer. All give a blank page after the login screen on page is also not loading correctly.

It’s the right address. I’ve even cleared my cache and it’s on my phone, as well. Sounds like several others are having the same issue. You’re the lucky one today! :grin:

Thank you for responding. Hoping for a speedy resolution!

same here as well.

Same here for about an hour now.

Wow…Ok, here’s hoping for a solution quickly! Tomorrow is my first show and I had my prints scheduled down to the last minute. That’ll teach me to plan! :grin:

Better than me, I have my first show in a few hours and saved a few prints for this morning. Lesson learned!:sweat_smile:

1 Like

Murphy is always lurking waiting for you to make plans that are critical that your expectations are correct.

This is so strange. Admittedly I have not tried it on my computer, but the site loads fine on Chrome on my iPad. I’m able to load a design and everything. Can someone for whom it’s not working on computer try again on iPad?

I have a computer, an IPad and an IPhone. Nope on all.

Was that on Safari, or Chrome, on the iPad?

I just tried on Safari on iPad and got same as you. But Chrome did work.

There are multiple threads on this being down this morning. FB, too. Hope it’s resolved quickly!

I know, but in the meantime it’s worth trying to see if you can get it to work on Chrome on your iPad. What have you got to lose? It would be nice to see another data point.