Not being able to print from the catalog

Unfortunately, again its showing I need to pay to print things. I’m a premium member. I am logged in. Thank you!

Which designs are you trying to print? I believe there are designs that are still not free even with premium. Can you link the design? Are you looking at only designs that are free with premium?

Yes free with premium.

When you click on the icon in the top right corner for profile, does it ask you to log in? It almost looks like you are not logged in. I know you probably logged into the website but the catalog is a different domain. If you click on the profile and you are not prompted to login, that is probably not the issue.

1 Like

It does not ask me to log in. Here or the catalog page. When I click on the catalog section and hit the icon it brings up all my purchases and shows I’m logged in. It had to be reset a few days ago because I was having the same issue.

I had responded to you a few mins ago and then deleted my post. I want to confirm that no one can see that post because it had all my personal info on it. I can be very blonde sometimes. Lol…If its still visible to other can someone from the company pls take down that post.

I’ve been having the same problem with the most recent free with premium things in the catalog. I’m getting a message that my premium membership is expired even though it is showing it paid through January 5th. There is no issue hitting the fast lane only in hitting the free with premium that I’ve not already loaded to my dashboard in the past.

They had to reset my account.


Any update on what needs to be done on my part or admins? Last time it needed to be reset.

Thank you!!!

Hi @Mamaseeta! I’m glad we were able to help you with this issue! No further action is needed unless you were still having trouble downloading the designs. If so, will you let us know which ones you were looking to add?

It has NOT been reset. Nothing has been done. It’s still showing I need to pay. If I am going to be charged the premium price I should have the feature at all times. This is the second time It has not worked. It has taken d.ays both times to get fix. You want me to pay the premium price but so far I have only had it 3/4 of the time. How much longer is it going to take for a tech to fix this issue? I’m losing my patience. I’m a new customer for under a month and have had nothing but issues. I can’t wrap my head around how paying customers are not getting what they are paying for. Please fix this problem immediately. I’m having other issues with this company/machine. I will be trouble shooting again today before I put a ticket in. I’m doing my part so this company needs to do theirs. I am using this feature as I will NOT be creating my own work. So I need it to be fully functional. So please have someone fix the problem. I’m getting the impression that everything is a stall tactic. Thanks for all your help!!!

I’m so sorry for my confusion. I’ve checked with the team and I believe a fix has been made. Will you please try downloading a Premium design again and let me know if it works? I’m going to leave this thread open to make sure we get this solved for you!

Thank you very very much! It’s fixed. I really appreciate you getting this done today. You have an amazing New Years!

Excellent!! I hope you have a happy new year too!

1 Like