Not Centering, Showing Solid White Laser Bed on Screen

Last week my GF Plus (purchased in January) showed “Lid Open” when the lid wasn’t open, so I chatted with support and had to pay additional to overnight ship a replacement black cord for the lid of the laser.

NOW this morning my laser was stuck on “Centering” and the laser head is not moving. When the laser is powered off and back on, it doesn’t make all of the normal noises, doesn’t center, and doesn’t calibrate. It just powers on and sits there.

Now I can’t find an area to chat with support-- I only see the option to send an email, which I have done. I have a second laser coming on 7/22 but I CANNOT be down for a week-- need to get this laser fixed as we have tons of orders to ship.

Anyone experienced this problem? How can this be fixed urgently? Cannot believe this is happening the week after a previous technical issue within less than a year of purchasing my machine.

Something is wrong with the system.

1 Like

Seems obvious to me, as well. Unfortunately I can’t actually talk to anyone at Glowforge about it to figure it out.

No, he means the system is temporarily down. There is a status page at https://statuspage.glowforge.com/# that tracks the current status.

Try refreshing your browser.

2 Likes

I’m sorry you ran into trouble. We were experiencing a system outage at the time of your report and I believe this caused the issues you were seeing. We’ve resolved the cause of the outage and you should be good to go now. If you’re using the App, you may need to refresh your browser.

1 Like

Oh thank goodness. It’s working now. Thank you.

1 Like

Fyi the laser bed is white till it gets an image to show and it did not have that image yet.

I’m glad it got resolved! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at support@glowforge.com. We’re here to help!