Not powering on

My glow forge was working fine yesterday. I cleaned it this morning due to yesterdays usage, nothing crazy just the lenses, crumb tray, etc. After cleaning it, it would read scanning, on the app, but nothing was moving. So I turned it off then tried to power it back on about 30 minutes later and now it will not power on. There is not an issue with the power source, as I have tried it in several plugs as well as plugging other things into said outlet… I checked the power cord and it is all in tact.
I am at a loss…

Do you have a Pro? Pros have an interlock staple on the back near the power button that cuts the power if loose/out.

I do not… I have a basic

The interlock does not affect power. It simply halts the machine, which then requires a restart (power off/on) to operate again.

Regardless, you don’t have one. It sounds like the power supply has failed. Start gathering up your box and orange bits.


GOSH I was hoping it wasn’t going to come to that… I guess its time to dig the box out of the attic

If you happen to have another computer cord you might try that first in case it is the cord. I had that issue on a new computer I purchased for a customer.

1 Like

I’m terribly sorry to hear that your printer isn’t powering on.

I just sent you an email with the next steps. We’ll continue to work on this with you there, so this post will be closed.

1 Like