Not Secure webpage

Hello All, it has been an absolute nightmare connecting and staying connected to the internet. I have had the GlowForge for three days and have yet to consistently print. I have tried everything suggested to get it to connect but nothing seems to work. I have noticed that the glowforge set up webpage is the only web page that is showing Not Secure and that is the only solution I can see that will resolve this. The only problem is that we cannot do anything about that, that is an issue for the developers to correct. Does anyone else share the same sentiment?

1 Like

Welcome to the forum.
Have you been able to successfully connect your Glowforge and attempt the first print?

1 Like

Yes but not much luck since then.

Once you have successfully connected, the Glowforge setup page does not enter into the picture. I am sure Support will be along to help you address what seems to be a local wifi issue.

1 Like

So when you are online and go into the page and your machine shows up there?

do you see status, changes, does it center, etc.?

the unit connects on 2.4G do you have neighbors with older gear. my might need to switch channels on your router. if your neighbors for example are on the same channel you might have too much traffic and that will affect your connectivity.


Ok Thanks, I’ve called tech support for my Wi-Fi they can’t seem to figure it out either.

1 Like

My machine shows up but offline and no activity. I will call tech support and see if I can switch channels. I live in an apartment complex that may be an issue.

1 Like

Does your internet come through your apartment complex? Do you have wired, ethernet internet available? Or only Wifi?

It definitely sounds like your internet setup is wreaking havoc with getting your GF working great. Depending on what the setup is I might be able to suggest options.

Many people have some success using their cellphone and creating a network from your phone to connect your GF too. If this is an option, I’d try that too.

Good luck!


I’ve finally connected to the internet by going through advance settings and obtaining the MAC address of the glowforge. The issue now is that my glowforge has been idle at centering the head of the glowforge for approxiatemly 30 mins now.

1 Like

Too long. Two options. - First shut it down.
Once shut down you can slowly slide the rail all the way back and the head all the way left, then turn the power back on and wait for the initialization.

Another option is one I use to sort of kickstart a poor initialization. Powered off, slowly slide the rail and head so the Glowforge image on top of the head is directly under the center camera on the lid. Power on and wait for initialization.

It takes a minute or two, but not 30…

As to the Wifi, support from glowforge, and possibly your apartment as well, will need to work it out. That phone assist has been suggested and worked for people as well.
On the plus side, once it is worked out, an interesting and fun adventure awaits.
Happy trails


Thank you I will take the suggestions and work on them tomorrow. Hopefully better results await.

1 Like

Hi @currya3291. I’m sorry to see that you ran into some issues with your Glowforge’s connection to your network. I saw you had also opened an email ticket for this issue earlier, and just sent you a response with some follow up steps to address this. To avoid any confusion, or miscommunication, I’ll close this thread so we can consolidate everything to your email discussion and will look for your response on there. Thank you!