One of the pins is bent. What do I do?

GF was taking over 20 minutes to center and home after initial turn on of machine. Turned off, unplugged for several minutes exited GF app and refreshed browser then tried again. Same thing. Decided to disconnect the ribbon and clean the lenses. Upon gently removing the ribbon, it looks like one of my pins inside the BASE receiving end of the ribbon connection is bent all the way flat. The pin is the last one on the left when looking at it straight on. I don’t know if this is causing the problem or if this is the way it should look. Never noticed it bent until now and its been printing fine until today. I should add, its been a few weeks probably since I removed the ribbon and it has worked okay since then. Any advice would be greatly appreciated!
I am not sure where to go from here. I am hesitant to reconnect the ribbon until I know whether this pin is supposed to be bent or not. If it is not supposed to be bent, how do we fix it? Also, why is it centering so long?

Leave it alone, the servers are down!

1 Like

Yes it does appear that one of your pins is bent, Not sure about what needs to be done to fix it tho. Support will be on the way to give you the best suggestion as to what you should do.

1 Like

Looks like it was bent all the way over when the plug was installed.

The only option would be to VERY carefully bend it back, but as far as it’s been bent over, it’s most likely to break.

I would not touch it until support tells you to, assuming that’s what they suggest.

1 Like

I agree, I am not doing a thing until I hear from support. I’m too scared it will break.

Hi @aprilevans0808 - I’m sorry to hear you’ve discovered this bent pin. As others have suggested, what we’ll need to do here is try and see if you can gently bend that pin back to straight with a pair of plyers.

Please give that a shot and let me know how it goes.

1 Like

Thank you for your reply. I bent the pin back very, very slowly from the base of the pin with some very narrow jewelry tweezers I have. I was able to insert the ribbon very carefully. I then was able to cut my medium acrylic. It seems to be working okay for the moment. So glad the pin didn’t break!!


That’s excellent news @aprilevans0808, glad to hear you’re back up and running. We’ve got this issue notated for your account, so please reach out and let us know if this does become problematic in the future.

I’m going to go ahead and close this topic, please feel free to make another one or email us at if you need any other help!