Orange Light...Stumped, Maybe You Can Help?

I have a glowforge pro which I previously could use for hours everyday without any issue. Now, I can use it once or twice a day for a 30 min. job and then the next job will cause my light to turn orange and my dashboard to display a header about overheating.

Here is what I have done to tried to fixed the problem…

  • Did a DEEP clean of my machine (crumb tray, lens, etc.)

  • Removed and cleaned the exhaust hose and cleaned the exhaust connection

  • Removed the carriage plate and cleaned the air assist fan

  • Made sure there was nothing under my glowforge blocking the filters

  • Went through the fan cleaning steps and let my fan run for 5 minutes

  • I have an air conditioner in my studio so I have a thermometer on the right side of my glowforge that shows it is always between 64-77 degrees

*Checked (and double checked) all the cords and clasps around and in the machine/lid

I know I am obviously missing something but I can’t figure out what it is. I have been talking to a GF specialist but since it is the weekend, I thought I would ask for help in the forums so I can still try and figure out what is wrong. I am getting REALLY behind on orders so any help/advice is really appreciated.


I’m very sorry for the frustrations. The most important thing, right now, is to get you back to printing so you can catch up on orders!

I’ve looked at the logs from your Glowforge and I have a workaround that will get you back to printing. I know that you’ve already received these instructions but if you encounter this error at the start of a print, doing this should allow you to get back to printing:

  • Go to and click through the prompts until you get to the ‘Start Fan’ page.
  • Click the ‘Start Fan’ button and allow the fans to run for 5 minutes.
  • You do not need to follow the rest of the “Fan Cleaning” instructions to move the Glowforge outside or use degreaser.
  • Click ‘Finish’ to exit fan cleaning mode
  • Try your print again

The team is still looking into this, but in the mean time, if you encounter this error, just go back through the steps to run your fans for a few minutes and you should be able to get back to printing.


I appreciate the workaround Jae!

I’m so behind on orders that if I need to run the fan between each project, I will certainly do it. :stuck_out_tongue_winking_eye:

I appreciate you letting me know that the team is still looking into my issue!

1 Like

Hey Jae,

The workaround didn’t work :cry:

I went through the steps and ran the fan for 5 minutes. I turned the GF off and on again and loaded up a project. The project uploaded fast and easy, the dashboard showed how long the project was going to take, the button lit up white and when I pressed it, the GF acted like it was about to move the laser arm but then the orange light came back and everything stopped suddenly.

I don’t think my GF is actually overheating because I haven’t used it in 7 hours now, yesterday I didn’t use it for over 15 hours and it still wouldn’t work. I don’t know if a sensor has gone bad or something? I am now just guessing randomly.

Let me know if you have any more ideas of workarounds that could just help get me caught up on orders until we can figure out the real problem.


I did not see where you inspected the ribbon cable to carriage plate connection. You probably took it off and put it back to deal with the air assist fan but any possibility of a bad pin or connection or even a cracked wire in the ribbon would produce the symptoms you are talking about. :thinking:

Hi rbtdanforth,

That is something I didn’t think to look at! I did take it off to deal with the air assist fan.

I just examined it and checked on the wires and pins and I don’t see any issues or damage. After I hooked everything up again, I just tried to do a project and the overheat warning came back up (I haven’t done a project in 24 hours so there is no way it is hot.)

I appreciate you pointing something out for me to check, let me know if you can think of anything else! :slight_smile:

1 Like

Thanks for your patience, and I’m sorry for the continued trouble. I’ve made a change on our end that should help resolve this issue for you. Could you please reboot your Glowforge and try again? Let me know how it goes.

Hi Vee,

I don’t know what you did but it seems to be working! I just finished one project and I was able to start a second project without any issues. I will let you know if anything chances but hopefully it is clear sailing from here on out :smiley:

I’m glad to hear that resolved it! Thanks for letting me know. If you run into any other trouble, please don’t hesitate to reach out. We’re here to help!