Phantom Circle


#1

Not sure why this is happening. I’m getting a phantom circle being scored into my map svg. I saw there was initially an error loading. But looking at the vectors in Aspire, I can’t find anything wrong. Anyone experienced something similar or know what’s going on here? Any help would be appreciated. Thanks. -Joe


WorldMapSVG.zip (905.0 KB)


#2

Phantoms are rarely phantoms. Might be easier to diagnose if you post your SVG.


#3

WorldMapSVG

I’m not having any luck uploading the svg…


#4

You might try zipping it and then uploading it.


#5

WorldMapSVG.zip (905.0 KB)


#6

Looking at it now. But, did want to mention - that it looks like Glowforge has improved their rendering/loading capabilities. I see this is about 50,000 anchor points!

I’m pretty sure, but you set this up to score, and not engrave, right?


#7

yes. score.


#8

I’m not sure what you ran into on this one. I just ran it and while it was a little scorchy (because a lot of overlapping border lines) it seemed to process just fine.


#9

hmmmm. thanks


#10

Do you recall what the error was when you loaded it?

I think I would definitely try to reload it.


#11


So, I re-uploaded it and tried it and it worked. Success!! … Then I scaled the design down to coaster size at just under 4-1/2" wide and I got the circle artifact again. (FYI: no error message upon loading)


#12

Ooh, if it’s scaling/rendering related, that likely means you have two points that are really close together, and when you get too small the distance between them is less than rounding error. (How you would test for that, i don’t know, but you might be able to do some simplifying of paths to find out…)


#13


I stretched the design back up to 6 inches and it was fine. Then looking for the sweet spot of when the error creeps in, I reduced it to 5 inches across and the circle popped up again.
Anyone have any idea where on/in the circle the rounding error might be sourced to generate this circle artifact? (top, bottom, right, left or center?)
I’ll start deleting vectors to try and find the offending vectors.
BTW: thanks guys!


#14

Looking at one of the earlier tests, there’s actually two circle errors. Makes me think the offending vectors are towards the tops of the circles…


#15

How long does it take to do those as a score? I wonder if you wouldn’t have cleaner results by rasterizing it and engraving it. It might be just as fast, given how much there is to score and the speeds you are going at.


#16

I don’t have any help to offer, but this is a cool bug. Good find.


#17

Actually… can you try and run this without the cut path on the outside? Scaled the same way that was giving you trouble earlier… I think it will be ok just to ignore that operation and run the score.


#18

about 15 minutes +/-


#19

I’m doing it now :slight_smile: My first test reduced down to about 5" saw the same circle.


#20

Here’s an interesting anomaly… when you select all, it shows a bounding box like something is way off to the side. But, I don’t see anything.