Printer arm will not move without resistance

I turned on my pro and heard a loud grinding sound and noticed it was the printer arm. It was stuck pushed all the way to the top and would not slide without a little force. I got it to start sliding without resistance and attempted a cut. It kept saying lid open when it was not. I have gone through a lot of troubleshooting steps at this point fixing one thing after another, but still keep having the same issue each time. I have cleaned everything, checked all of the connections and belts, and it is still hard to move. I attempted a cut after thinking I had it fixed and it seemed jumpy and cut off to the right and with cuts that did not match the image (like squiggly lines). I am not sure what else to do at this point. HELP!!!

I attempted another cut and it did not make the same noise and appeared to be working fine, but still cut off to the left and not as the image should be. I noticed this time the belt under the arm appears very loose and it was not before.

Was this done with the machine on or off?

I have had it on and off multiple times as I have tried to troubleshoot, but off when moving the arm and checking everything.

I don’t see a spot to share pictures/videos on here or I would share what it is doing

Just drag a photo in and drop it in your post. If the video is too long do a YouTube and drop a link.

1 Like

The belt underneath your laser arm is so loose that it is hanging down…something is very wrong with it. (Probably what caused your issues.)

There are instructions here for checking it:


Something’s up with that belt. If you’ve taken off the carriage plate to clean the air assist fan, you might not have gotten the belt back on correctly.

The instructions for removing and replacing it are here:

1 Like

I got the belt fixed (did not realize I loosened it while cleaning the air assist fan). I made another cut and it worked fine. I tried another this morning and it still looks good. I am happy it is working fine, but still don’t know what was causing the arm to get stuck. The loose belt was an issue I caused while trying to fix the original issue. Hopefully it just does not happen again or to anyone else because I could not find any topics on it either.

1 Like

Thanks for everyones help!


I’m glad you resolved it! Thank you everyone for your advice. I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!