Problem with Glowforge App - missing menu in black bar at top of screen and side display

I was trying to cut tonight. I was trying to use a file from the dashboard and the menu at the top of the app completely disappeared. I did my settings and I pressed print… it gave me a print time and blue button . When I pressed the blue button it started printing. It did not give me the countdown of the time (the whole right side of the screen which usually shows you this was blank) which meant there was also no option to cancel the print so I cancelled the print by turning off the power. So, basically the entire menu at the top disappeared as well as the side displaying the print information. I normally use Firefox but also tried on Chrome but menus still not there. I was advised to clear the cache which I did, and rebooted the machine. It didn’t help. Luckily it does still work to print through my IPAD but as all my files are on the laptop I need to figure out how to fix the app on my laptop. I have only had my glowforge a short time and feeling frustrated as so far I haven’t had any issues. Any help would be most appreciated. Thank you.

See More

You mentioned rebooting. Was that your laptop or your GlowForge? I’d recommend restarting the laptop if you have not done that yet.

I rebooted the laptop a couple of times.

Chrome is currently working fine on my Windows 10 computer. My computer just updated to Version 89.0.4389.82 (Official Build) (64-bit) although the previous version was working fine this morning as well.

Since the Glowforge is printing as expected, and will print from your ipad, it seems the problem is with your computer interacting with the interface. Perhaps a browser update has a new ad blocker or some other interference. Perhaps you can try a print and then share a screenshot of how the interface changes and “goes blank” so we can see what you are seeing. As for not being able to cancel a print, you don’t have to turn the power off. You can simply open the lid.

1 Like

This happens on my MacBook sometimes when I use the pinch to zoom on my touchpad. Closing the browser and reopening always fixes it for me, though.

You’ve opened a support ticket by posting here, so they’ll be along soon to help out. They’ll want you to go to and copy the URL there for them, so you could save some time by having it already posted for them to see.

@pamela.henwood I’m so sorry to hear on your Glowforge app everything is not appearing.

Thanks for letting us know. We need a bit more information to investigate. Please do the following:

  • Information about the browser you are using.
  • A screenshot of the error you are getting.

Please do the following:

  1. Go to
  2. Look for the header that says “Your web browser’s unique URL”
  3. Click the button that says “Copy URL to Clipboard”
  4. Reply to this, and paste in the link provided

If possible, could you please send me a screenshot of what you see in the Glowforge app when this happens? Make sure to include the rulers in your screenshot and show as much of the bed as possible

To take a screenshot:

  • Mac: Press Shift-Command-4 and click and drag a box around your image. You’ll find the screenshot file saved on your desktop.

  • Windows: Click on the Start Menu and type “snipping tool”. Open the Snipping Tool > New then click and drag a box around your image. Click the Save icon and name and save your file.

This will help us understand the circumstances around your error so we can work on it for you.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email