Problem with parametric values in fusion 360


#1

Hi glowforgers,

I start training myself on Fusion 360 with glowforger’s tutorials. Great job really!!! Thanks for all. I must say I am a complete new user on this software so I start with the basics.

I become able to do a finger joined box quite quickly. And to use the powerfulness of parametric software, i used all parameters for my box. I was proud of me at the end.

But, then, i had a bad surprise when I wanted to change one parameter to see if my box would adapt correctly. And the answer is NO. I think i have found from where comes the problem but I don’t know how to fix it.

Explanations on my making process:

First, I do the box’s bottom (easy)

Then I make a copy of this to make the top and translate with a “height - thickness” distance (easy too)

Then I make a side of the box. (easy too)

At this point, if I change width or depth. It’s perfect. My object adapts correctly to new variables. The problem is when I change thickness or height. For exemple, if I change height, here is the new object:

So the problem is the distance used during the copy process. Even if I write parametric values, it seems that it calculates this value and transform it in a constant value. So when I change height, the distance between the two copies doesn’t adapt with the new height’s value.

I have tried the two ways to do copies mentionned in one of tutorials but it is the same.

I don’t see where is my mistake. I’m sure it is just a little something but I can’t see what?

Does anyone knows?

Thanks for all your work on tutorial folks. It’s really great.

Marc


Parametrical boxes in Fusion 360. Solutions to my problems
#2

I am not sure how easy it is going to be for me to explain it, but I ran into the same problem with my first couple of files.

When you design with parameters in Fusion 360, you have to be careful to specify the relationships between “the distances from one object to another” in addition to specifying the size and placement of those objects.

It just takes practice. Start with one reference point, and then build everything off of that one point if you can. If you start a new part out away from the original, then it doesn’t adjust well parametrically.

I know that was a terrible explanation, but it’s the best I’ve got. :smirk:


#3

I’ve not used Fusion 360, but in Inventor, and without seeing how you’ve set up your constraints its hard to say what exactly is not working. But, have you tried using the rectangular array tool?

In the array dialog you can use a parameter as the distance/pitch of the plates, no other constraints needed.


#4

Move/Copy commands are not “captured” and driven by parameters in Fusion 360.

To do what you’re wanting is still possible though. You need to assign Joint constraints which you will find under the “Assemble” menu. When you select the Joint command, you will pick one point on the first object, then one point on the second object, and you will see the two objects move together as those chosen points are brought together. Don’t worry! In the dialog box that pops up for that command, you can specify an offset distance on X, Y, or Z axis, so you enter your parameter for Height there. The components will then move into proper place.


#5

In F360 there are always 3-4 ways to solve the same problem.

This is how I do it.

Go to your parametric values spreadsheet. Create a value for the distance you need the copy moved. This will be a formula not a fixed value. I/you will have to play around some to get it to work right but it will be something like this: +hight-thickness, sometimes depending on the direction, it will be -hight+thickness.

You’ll get it. If I can, pretty much anyone that is tenacious can.


#6

That will only make the initial copy of the object at that location. If you change the value of the parameter itself after the copy is made, the location of that copy will not update. I did test this before I posted my comment just to make sure.

The reason the Move/Copy is not driven parametrically is because then you could not specify Joint assembly. The values would combat each other.


#7

It looks like I need to get this fully figured out an then add a tutorial. Joints you say?


#8

This may help.


#9

[edit]
I’d like to stop using SolidWorks (well, I’d like to stop paying for it) so I decided to take this as an opportunity to give myself some more Fusion 360 practice while also potentially helping-out @marc.simon1, but I’ve been trying to use the method I mention below in Fusion 360, but Fusion 360 is refusing to cooperate.
[/edit]

What I would do* is make the bottom first (as you have), then make a side next. Don’t create the top body until the side is made. Once the side is drawn up, then copy the bottom body to create the top body. Create a joint between the side and the top to hold it in place.

The main difference in this approach is that the location of the top is being defined by the geometry of the side instead of the geometry of the side being defined by the location of the top. This is better because, as you’ve seen, defining the location of the top, without physical geometry to snap it to, requires extra steps.

*in SolidWorks


#10

I was also having issues with parametric values, but it was in sketches, not even (just yet) in the bodies. I’ve been working on a clip-tenon setup, and it was driving me nuts that every time I’d test changing d/w/h values, sketches would freak out and move everywhere instead of staying in place in the corner.

I eventually got it sorted out with a lot of effort, but with major PITA effort. The difference between “distance from origin point” (x:0,y:0,z:0) and “distance from (left) plane to (right) plane” will screw you up big time.


#11

I recorded a video of a hack/technique you can sometimes use to coerce Fusion 360 into resizing models. Basically, sometimes doing many small changes will work where one large change does not.


#12

Grrrr… I’m currently on a hate-relationship with Fusion at the moment with parametrics. Like you, I ran into limits with it. It seems to be horrible when it comes down to recalculating formulas.

I actually gave up on mine (in Fusion). I might try something similar again in Onshape, but I’ll probably just wind up using OpenSCAD.


#13

Usually, calculation issues are due to insufficient constraints in sketches. The latest update of Fusion now has a feature where sketch features turn from blue color to black once they have been fully restrained, to help avoid having those undefined features causing the model to break.

This is something that happens in Fusion, Inventor, Geomagic Design and PTC/Pro Engineer.


#14

and OnShape.


#15

This happens even in OpenSCAD. The issue isn’t the tool, it’s in carefully expressing all of the parametric relationships so that when you change values the right thing happens. It’s tricky.

In Fusion I’m finding that using Sketches with Dimensions, and then extruding from there, helps make all of the relationships visible and explicit, which makes it easier to troubleshoot odd behaviors. Transformations can get tricky, because some preserve the relationship and some don’t. Mirror, for example, does, so you could mirror the bottom of the box through a bisection plane to create the top, and that should work, I think.


#16

Oh, the other approach to this could be to move back in the timeline and edit the move. Not elegant, but it’d work for a one-time change.