Purchased Images Will Not upload

I have purchased a few files and here is one of them, they simply will not upload - I have gone in and rasterized, simplified, etc… any other suggestions?

Uploading purchased files to a public web-site is a no-no and likely in violation of their terms of use.

Just to check for you, however, I went ahead and downloaded it, then uploaded to the GFUI - it took 3 seconds to upload and process. No issues. Then I deleted the file.

That is a very poor image for engraving, what were your plans for it? Very low contrast, unless that’s what you were hoping for.

1 Like

I do not understand the no-no - I bought these files off a designer on Etsy specifically to engrave on leather - this is the simplified version, after rasterizing it, etc,… the original files were 10mb - for the svg file, I was trying to drop the file size, that is why this image is so grainy, it wouldn’t upload the lower resolution one either.

Posting here is violating their rights. If they wanted them publicly available, they wouldn’t be charging for them in the first place.

No different than sharing design files for cutting, for example.

As to file size, I had no issue with what you posted and I have uploaded and printed raster image files much larger than 10MB. The largest I’ve printed is 18.2MB (although the UI accepts up to 30MB) and it takes 43 seconds to upload (~5s) and process (the remainder) - I just uploaded it to test for you. I do not have the “premium” fast lane.


You purchased the file to make items. You don’t have the right to sell or give away the file.


Thanks for clarifying - well i am at a total loss because we have tried everything

Try dragging the file directly onto the interface rather than uploading.


… or try a different browser. I use Chrome exclusively.

Another thought - what is the speed of your broadband? That really shouldn’t cause an issue, especially with the small version you posted above.


I have tried dragging it in - still no luck
I am using Chrome

Can you try uploading the original file they sent you before you rasterized it?

You didn’t answer what your broadband speed is (for upload), and I’d be curious to know the original format if not JPG.

0.72 is upload speed
I got the files in a png, svg, and pdf none of them will upload 3 separate files, from 2 different vendors

This is just for engraving, yes?
Have you tried converting the file to high quality jpg?
Or uploading via your phone (to eliminate your Wi-Fi as the culprit)

All of those file types are supported. I just uploaded an 8+ MB PNG in less than 2s, and another 4 or so to “process” before the workspace appeared.

There’s something going on with your computer or browser. Suggest you go to whatsmybrowser and send the resulting link to support.

1 Like

Thank you - I have done this

1 Like

I have not tried from my phone, yes just for engraving -

Then give uploading from a different phone/tablet/other computer a try. Once it’s uploaded it’ll be on your dashboard and you can work on it from your regular computer.

When you say “will not upload”, what actually happens when you try?

1 Like

I get an file upload error

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.