Purple Magic Button- Help!


I tried running a print today, and everything seemed to go as usual except I noticed that the glowforge actually didn’t cut/engrave anything. I turned the machine on/off and noticed the button would be purple, then turn off. When I tried to run another print, the button blinks as usual but would not respond.

Any help would be appreciated! Thank you!

My button turned purple after the machine stopped engraving mid-way through a 3 hour engraving job. It never worked again. This is something only Glowforge Inc will be able to help you with. To open a support ticket, email support@glowforge.com. Include what you said here, along with the date and time of this job when the Glowforge stopped working and the button turned purple.


Thank you for the reply, Dan! I’ve emailed support. Unfortunately after some research I’m starting to think I’ll have to send it in for repair.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.