Purple Magic Button

Hi everyone. I’ve got a purple magic button that will not go away. I have tried resetting, turning off and waiting, everything I can think of.

I know it’s a diagnostics mode indicator. But the previous suggestions I found by searching here have not worked.

The epoxy on my lid failed, which started a cascade of problems. I have two Glowforges, and this unit’s front lid lip fell off when its epoxy failed (on my other unit, the epoxy at the rear of the lid failed). When that happened, the connection from the lip to the right LED strip broke off. I had it running with a persistent “Lid Open” today, then installed the right LED from the now-dead rear-epoxy-failed unit (that unit died because the epoxy failing caused a short in its read circuit board at the hinge). So yeah, I now have a Glowforge graveyard starting. But I am hoping I can get the purple magic button unit at least limping through the cuts waiting for it.


1 Like

I think you are going to need to contact support to get assistance (and as you probably already know, they don’t monitor support issues here anymore).

Good luck, hope it all works out.


Thanks for the luck. I think I’m going to need it. I contacted them, and know they don’t hang out here. Just throwing a Hail Mary and hoping someone here knows something.


A purple button is basically a failure of connection to the internet. There can be many causes from your Wifi, to what the machine does about that connection, and perhaps something of both.

For a lot of reasons the machine is extremely sensitive and can have wifi issues even when the rest of the equipment in the house does not. It may be that moving the unit or adding a jumper could solve that. In any case having a strong wifi connection will be good for all machines.


Yeah that’s the real mystery here. It’s run for years (with a lot of use last month) in the same spot, and now just isn’t having it. I really wish they had used better epoxy on this glass. I am all kinds of careful with this thing, and have had three instances of the glass popping off ( back of two machines and front of one). I’ve gone from hoping for a solution to clearing this purple button to hoping for a refurbished unit. No amount of button/power combinations will get me back to teal that I have discovered. Or to any print head movement.

1 Like

Something as “simple” as the neighbor getting a microwave can ruin your wifi for a glowforge (it has apparently managed to happen) The whole thing is far beyond my knowledge, and fortunately the only time I had the problem it was the internet supplier that shut off the 2.4 ghz source. Having someone from your ISP check out the possibilities might help.

1 Like

To be sure that wasn’t an issue, I just fired up my (other) broken Glowforge to see if it connects, which it did. What a mess. But thanks for the possible lead.


Purple button doesn’t have to be related to wifi. There are several things that can turn the purple button, one of which you can even control – putting it into diagnostic/recovery mode will illuminate it purple. If you haven’t done that, think of it as a generic “something has gone wrong” state.

I had a Glowforge that sparked and smoked from somewhere in the back of the machine, the tube stopped firing, and the button turned purple. That machine continued to connect to wifi and go through the motions, it could be restarted and it’d center/home, it was on the internet just fine, but the tube no longer fired.


You’d think after all these years they could have compiled a list of the possible causes of each color so that owners could at least eliminate the things they can. It would save support a lot of effort.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.