Push Button and Nothing Happens, Purple Button

My glowforge button glows when it is ready to print, but when I push the button nothing happens. I have tried to reconnect to wifi, but when I hold down the button it just stays white. I submitted a request to them but am waiting on a response. When I first turn the machine on, the button glows purple for a few seconds.

Could be bad switch, cable went bad, or board issue. About the only thing you can check is the wire connection to the button.

2 Likes

I appreciate your response! Unfortunately I have checked all of the wiring, and it all looks connected.

Welcome to the community!

Add to the original thread you opened with support and give them the approximate time of your problem and the time zone you are in to help them zero in on the machine logs.
You need to hold down the button until it turns blue/teal, around 10 seconds.

Support will eventually get to you. Did you get an automated reply to the first email you sent? If you didn’t, check your spam and promotions folder.

3 Likes

Okay I will add the time, thank you! Yes I tried holding down the button multiple times, but it never turned teal. It just stayed white.

1 Like