Render errors, offsets, and no cut-through problems


#1
  1. The photos show large offsets of over 9mm from the placement of object and the cut. Two separate uploads were needed to Render/Print these. Offsets were the same. Why is Calibration so far off?imageimage
  2. During upload Render attempts; “Unexpected Error Occurred”. Is there a way to get large file sizes to render?
  3. Using Proofgrade Material and magnet hold-downs, there are too many cases of not quite cutting completely through. If you could know this, a second pass at reduced power could be made.
    How about a photocell installed on the sidewall below the crumb tray so that light from a cut-through could be monitored? Imaging not required, just scattered light level monitoring to see if cut came through.

#2
  1. That object placement does seem slightly larger than usual, so reporting it here was the right thing to do. I can see that you are cutting on Proofgrade material, so the thickness of the material is not likely a part of the problem. (What was the date, time and time zone for the above prints? Knowing that can help Glowforge to diagnose the problem.)

  2. There can be different causes for why a file won’t load. If you want to Zip the file and upload it here someone can probably take a look at it and maybe give you a more specific recommendation.

  3. Try using these Honeycomb Pins to keep the material locked down. They work really well to keep the material flat.


#3

Can’t help with all of your questions but the first couple are ones that have been covered fairly well & have pretty consistent responses.

  1. the post-processing view won’t line up with the actual cut. It’s often relatively far off and sometimes it’s not. It shouldn’t impact anything. If you needed to repeat a cut (for instance you want to do another pass) if you send the job to print again it will be perfectly aligned with the first pass, it’s only the post-processing image that appears misaligned.

What matters is the initial placement of a project. The placement before printing may have up to 1/4" misalignment vs where it looks like it will hit on the material. It is usually not this large (my machine is only about 1mm off) but it is a published limitation & tolerance now. They are working to tighten it up and the number of us who don’t see that much of an error suggests they should be successful. So if where you place the design is within 1/4" of where it actually cuts, you’re within tolerances. If it’s not then it’s an issue for Support to try and address. A simple test is to draw a line or set of crosshairs on the material, make sure the material height is defined correctly and then try to drop a design right on top of the line or crosshairs.

  1. file size is an issue if the thing will take more than about 3 hrs to execute. You can reduce the time by reducing the LPI - the high LPI values (over 225) tend to cause large increases in execution time and if the file is large (in square inches) that can exceed the 3hr buffer.

The other type of large file - the ones that are very complex with many nodes/paths can be addressed by reducing node count in your design software or by breaking it up into smaller pieces. There are tutorials on how to do that. The size limitation is another they’re working on and should get resolved when they move to streaming the file to the GF vs downloading the whole thing before starting the print.


#4

I have not been having precut placement vs actual cuts, until yesterday when I had two uploads each with about 9mm offset between placement and cut. this is larger than 1/4". Then the machine re-calibrated itself, and placement and cut were fine again. I have no idea how to prevent or cure the problem. The post-processing view was never the issue.

My solution on the Render error problem, was to break up the original file into four parts, just as you suggested. It took several attempts to get file sizes that were accepted. Since I was having problems with getting cuts pretty far off the placement view, it was a learning process to see where the cut would land relative to my “aim”.


#5

As mentioned, 1/4” between camera view and actual burn location is the current spec. The most common culprits of placement being greater than this are: warped material (which affects the material height and camera dewarping), an incorrect manual material height entry, the head losing steps - either from a collision with something (material or outer boundaries) or being accidentally moved.

That the problem corrected itself with a recalibration makes me wonder if either the head collided with something (this will usually show up as a shift in the middle of a print) or was accidentally moved a little bit.


#6

The file is a planetary gear contraption and the gears have many nodes. I split this file up into four pieces to get each one to render. There were no changes other than splitting then saving as plain SVG for each of the pieces that worked.
gear 10 Inkscape 4X squares planetary square sun plain.zip (146.7 KB)

I am prone to Pilot Errors, so hope this zip attempt works.


#7

Oooh! Yep, that’s a lot of nodes!

I’d do a Simplify Path.

For instance, the large gear - Ungroup it a few times, select it and go to Object > Path> Simplify > Curve Precision 100%.

It reduces the number of nodes in it from 8038 to 449 without affecting the shape.

Do that for each of the gears, it will probably reduce the file size enough to load it as one file.
(And yes it does.)


#8

This sounds like what I need. But in Inkscape 0.92 going to Path ->Simplify gives no options, i.e. there is no Curve Precision 100% option. Also I cannot find any Preferences parameter for even adjusting Simplify Threshold. Besides without a “curve Precision 100%”, I worry that the gear teeth shape will change just using Simplify alone.
There is an LPE Simplify I found and never used. I have no idea how much the curve shape is changed using that route.
Hey, I don’t even know how to count nodes in Inkscape!There is an Extension for Node Numbering but you have to hunt for the largest digit.
Maybe Illustrator has the feature you mention. But I do not have that software.


#9

Whoops, sorry! My bad. It opened in AI, I assumed it was an AI file.

I don’t know where to find the settings for Simplify - assuming they have some that allow us control over it. (This might be one of those differences between the programs that you pay for.)

I’m not sure the Inkscape Simplify is going to give good results for this kind of file…it looks a little rough and the gears might hang up. :confused:


#10

When you click on an object it shows the node count in the status bar on the bottom of the screen. If you select all (Ctrl+A) it will show how many nodes are in the whole design.


#11

For Inkscape 0.92, my status bar at bottom of screen shows only the following:
Left side: Fill, Stroke; Opacity; Toggle Current Layer Visibility. Lock/Unlock Current Layer.
Right Side: X: Y: Z:
Maybe I’m missing something in Preferences to see the number of nodes?


#12

Looks like 92 requires you to ungroup everything because it won’t display both the object type & the nodes. Then click on a vector object and it should show something like this just to the right of the Fill/Stroke boxes in the left corner:
Path 241 nodes in root. Click selection to toggle scale/rotation handles.

That’s the Notification Area of the Status Bar. It’s context sensitive so it changes based on what tool you have selected and object if any. If you don’t have anything selected it will say something like “No objects selected. Click, shift + click…” Click through the tools on the left toolbar and you’ll see different info that can be helpful. With the selector tool (arrow) and a vector object it shows you the node count.


#13

Got a test to work … Thank You!
Ungroup. Click on Node Tool which now shows all nodes. Then must use Ctrl A to re-select these nodes to get the node count. The second selection turns selected node blue. This second “selection” is necessary.
I think getting Illustrator may be a next step for me.


#14

Does anyone know the upper limit to node count for successful render?
This would help to know how to split up, if possible, jobs with high counts.


#15

No, we don’t know, and they’ve never said.


#16

I think it’s more than just a total node count but I can’t confirm that. And I haven’t looked at your original file (yet) to get an impression.

I’ve (and others) have successfully loaded files with 20k plus nodes.


#17

I’m sorry I’m late to reply. Thank you for your help, everyone!

First, I’m glad your alignment error has cleared up. If you notice any issues with your alignment in the future, please let me know. I’m happy to look into it further.

Second, there are many factors that can cause trouble with uploading, so unfortunately, I don’t have a specific number of nodes to share with you.

Finally, regarding the cut through issues, are there any specific prints I can look into for you?

In general, to cut successfully, there are three important things to check. First, your material must lie flat. This requires a clean, properly installed crumb tray and flat materials. Second, there must be no obstructions, dirt, or damage preventing the laser light from reaching your material. Third, your design must be set up properly - for example, with lines that are fully on the material and that are set to cut. It’s hard to know which issue might be affecting your print, but if you follow the instructions in the cut-through troubleshooter, we’ll be able to get to the bottom of it.

If you still run into trouble with your prints cutting through after following these instructions, please let me know.


#18

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.


#19