Replacement cable didn't fix the issue

GF was stuck on scanning, couldn’t take a picture. LED lights all work. I was send a replacement cable that I received today, GF still doesn’t work. I am very familiar with laser printers, my GF is only 3 months old. It is immaculate, very well taken care of. I follow all the steps on the instructional video with it only to give me the same error messages again.

Any advice. I keep rewatching the video to make sure I installed correctly which I did, my connectors are all perfect, machine clean, WIFI single strong. I have no idea what to do

If it’s installed correctly, it sounds like one of the connectors is damaged, or perhaps some of the electronics associated with the lid cable has failed.

Send that info to support, the machine will likely need to be replaced.


thanks so much for the response. Everything seems to be on track. I’m very thorough and meticulous with my equipment. I’ve checked several times. Sent photos to customer service. It has to be some sort of defect in the machine because it just stopped working. Hopefully they send a new machine because I do really like this brand

1 Like

which cable did they have you replace? There are a lot of cables in the machine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.