Replacement Machine Does Not Turn ON

After having issues with my first machine (purchased in December 2020) I received a re furbished replacement on Friday, February 19, 2021. I was able to complete approximately 4 projects. This morning, when I turned it on, it lit up briefly, then simply went dark. I unplugged everything, checked all of the outlets, but still nothing. To say I am disappointed is a severe understatement. I simply do not have the time nor the energy to be battling with these machines that cost so much. Thank you for your timely response and resolution.

Oh no, I’m so sorry to hear you’re experiencing trouble with your replacement.

Your Glowforge should be plugged directly into a grounded wall outlet that meets local building codes. If you haven’t already, please do the following:

  1. Unplug your Glowforge from the wall
  2. Plug another device directly into the same outlet and see if it works
  3. If the device does not work, have an electrician investigate. It may be a blown fuse, a broken outlet, or something else
  4. If the outlet works, unplug the other end of the cord from the Glowforge unit itself
  5. Inspect both ends of the power cord; if you notice any damage, try another power cord
  6. Plug in the end of the power cord that goes to the Glowforge, making sure it is inserted all the way in
  7. Plug the other end of the power cord into the outlet, making sure it is inserted all the way in
  8. If your Glowforge still won’t power on, try another outlet

Let me know what you find!

Besides using another power cord (which I don’t have any additional) I tried every method you have listed above.
Every other device that is currently connected in the same room as the Glowforge is working fine, including this computer that I am currently writing to you with.

Is there another type of cord I could use to test it out? I didn’t want to try that for fear of ruining something. Thanks- Cara

It’s a standard PC type of cord. Nothing otherwise special.

Unfortunately, I do not have any “standard PC cords” laying around. Perhaps Glowforge should send me another one to try.

I retract my last email. I was able to locate the same power cord that was being used on my Sawgrass sublimation printer. First, I tried using the cord that was being used for my printer on the Glowforge. Nothing. Then I used the Glowforge power cord and plugged it into my Sawgrass, and it works. So from my position here, it seems that the Glowforge itself, not the power cord is the problem.


So I am wondering, where do we go from here? I am losing money every day that goes by that I am without a properly working machine. If you are unable to provide me with one, please let me know. Thanks, Cara

Thank you so much for working through those troubleshooting steps. I’m so sorry for my delayed response. I’m going to need some personal information from you so I’m going to reach out via email. I’ll be closing this forum post to simplify our communication.