Saved settings are storing pattern as NaN

It seems that saved settings are often saving the pattern as “NaN”… this results in me not being able to modify the pattern, and any grayscale image shows as a solid fill… I have to go to manual and retype all the settings…

Do you mean the design that is saved in the library when you mean ‘saving the pattern’?

Alas I have always had issues with my designs being saved properly or showing the current project name, or even loading from the library (select a file to open and something else loads)–but after a page or two of images, I found it was MUCH easier for me to just upload from my computer & my file structure is set up as i find is most efficient for my way of working…

But for settings, I do have many saved named for the MATERIAL that I’m using. So I do have to select it each time I am using a design & not PG material or settings, so not as optimal a solution as the settings saved with the design–but easier if you want to use the design on different materials…

I haven’t seen “NaN”… got a screenshot?

Are you saying when you save the settings, what you type in the “Give your setting a name” dialog is lost and it replaces with “NaN”?


Hi, no I am referring to the “Pattern Density”
When this happens, I cannot modify the value either… it is stuck on NaN

See this image:

1 Like

It appears to be a display bug, the settings are saved correctly but the “slider” scales to the width of the saved settings.

Flip it to “patterns” then back to “dots”, and the slider re-sizes with the markers at the correct points.

At least, that’s how mine is working.
(Change to patterns, then back to dots:)

(I’ve never seen any writing underneath like yours, though)

1 Like

I haven’t either, that’s a legitimate bug. (Couldn’t figure out what NaN was from the original post.)

Did refreshing the browser do anything? What browser are you using?

1 Like

weird. NaN generally means “Not A Number”. So almost certainly, as other say, a bug.

1 Like

The writing appeared after the last update… it says “(Beta) Margin Optimization”
As for Switching to convert to patterns and back, this does not fix the problem. It is still stuck on NaN.
I do not think it saved the settings either, if I put in a grayscale image, it appears all solid
See this example: 1 is with the saved setting, 1 is with manual setting

I am on chrome… and this happens at work and at home

We’re talking about the “NaN”, not the margin optimization setting. Nothing like that shows up for us.

I’m sorry you ran into trouble with your settings. Thank you for letting us know about this. I see you already emailed us about this and I’ve followed up with you there, so I’m going to close this topic.