Scaling wrong when saving SVG?

nhf

#1

I downloaded a template from thingverse, but am having to modify it slightly so that the tabs actually fit. My issue is that when I save the SVG file in illustrator, the scaling is modified when I upload it to the Glowforge app. Here are my settings when I am saving the SVG:

Here also is a side by side comparison of what is happening. The left is the original SVG provided by thingverse, and the second is my saved SVG, without changing anything and only doing a “save as” function.

If I have to, I will scale my edited version down to the original, but this step could lead to complications when I upload the other parts. I would really like consistency, especially if I want to make multiple of these in the future. Any help would be greatly appreciated!


#2

Uncheck responsive. If working in inches, change the Decimal Places to 3.


#3

Unfortunately, it is still resizing. Any other ideas?


#4

Working in Illustrator, the only “gotcha” I can think of regarding scale oughta be Responsive (the intent of responsive is to scale for web, which we definitely don’t want).


#5

I noticed that design has slots - you pretty much have to adjust those before saving the file from Illustrator, because the likelihood that the person who designed it and loaded it on Thingiverse did not use material the same thickness as what you are using is incredibly high.

In other words - might not be a resizing problem in the GF interface. Might be a design that needs to be slot adjusted first.

These settings work for saving AI svg files.


#6

Actually the person who made it had it pictured with a Glowforge, and
someone else also commented that they made it on their Glowforge and it
worked perfectly! So I am guessing it is something wrong on my end.


#7

Ah! And you’re using the same material that he/she used?

Might be the settings then. Although if you uncheck responsive and all those other options in the Save dialog, it should save the exact sizes. Anything I bring over from AI is exact.


#8

this is probably more important than whether they used a glowforge. if you’re both using the same proofgrade, you’re probably ok. but even if they said “i’m using 1/8” baltic birch," their BB may be .118 and yours might be .123. or vice versa.


#9

But, you guys, what about his side by side comparison of the SVGs? They’re loading in the UI at different sizes completely. Something is changing about the svg that is making GFUI interpret it differently and it seems unlikely to have anything to do with material thickness. Seems most likely that AI is doing something to it on either import or export.


#10

Hmmmn. Good point. I would look at discrepancies between units used in whatever program the original file was created in and AI. (In other words, it’s likely a scaling problem before it ever gets loaded to the GFUI.)

I’d measure some parts in AI and see if they are the same as the original you cut, before exporting the SVG from AI. You might need to scale it there before saving the SVG.


#11

I think I recognize that file from thingiverse. If it is the same version that I downloaded, then it is not you! I had to do a lot of tab/hole/slot manipulation to get it to work.


#12

Are you using this model? jamiekin’s Glowforge optimization of the Dymaxion Globe: https://www.thingiverse.com/thing:2762172


#14

Ah, I used the previous version that one was remixed from, https://www.thingiverse.com/thing:2707484, which had some issues, but came together eventually.


you can kinda see how the slots in the triangle pieces are still too wide.


#15

Yes! It is this one. I am trying to eliminate that space :slight_smile:

I am glad I am not the only one then! The file is saved as “3mm” so like @jules suggested there must be some difference in that, perhaps because they created it in a different program other than illustrator, when the SVG is loaded the settings are changed?

This seems like a problem that might have to be solved with a lot of guessing and testing unfortunately. Thanks for everyones help!


#16

I don’t think it’s a design program fault. I think that it’s just a less than perfect file, unfortunately.


#17

So I downloaded a DIFFERENT file by @CharlesDarwin in hopes that since it was made with the Glowforge and posted on the forums that it was made to be a better fit, and it is!..HOWEVER, here I am again trying to edit the original SVG and am having the same problem BUT WORSE. Now the SVG is waaaaaaay smaller (and mirrored???) when I save it, and no matter what settings I use in illustrator, it continues to not save to scale. The left is the original and the right is my saved version.

This isn’t something that I want to have happen with every single file that I download and then try to edit. Anyone else have suggestions?


#18

Post the SVG file that is not to scale and a screenshot of your SVG export/save as settings.


#19

@mhersh150, I think @jbmanning5’s suggestion is great - would you willing to post that, or have you found a solution already?

It does appear that there’s something unusual about this file. It might also be a good idea to create a very simple rectangle in illustrator and make sure that, using the settings you’re using, it uploads at the scale you expect.


#20

@Rita and @jbmanning5, I have discovered the issue of why it became so small. For some odd reason, when I open the SVG file, the artboard dimensions turn to 3" x 3", thus when I have save it, the artwork is extremely small. I am not sure why when I open the original SVG file that it does this and why the original doesn’t upload to the glowforge at 3"x3", but I am ready to move on from this. Thanks for everyone’s help!


#23

What a great discovery - thanks for letting us know!