Turn on GF, it powers up and makes its noises and then it just says…

I’ve read thru the posts and found a ton of people having this issue and so I have tried everything mentioned and nothing is working.
Please help if you have any suggestions! Thanks!

Checked wifi / cleaned with wipe / took off carriage plate & cleaned fan
Tried all of these from GF:
In the event that you run into this sort of behavior in the future, I’d like to recommend the following steps to see if they help:

If you’ve followed all the troubleshooting steps on the official support page for Stuck Calibrating, then it’s quite possible you will need to replace the black lid cable.

If the machine is under warranty, and support determines that’s the best next step, they will send one. Otherwise, you can buy it in the Shop under Parts.


If you are getting the clicking from your print head then it has connected to wifi and so you can rule out wifi as your issue.

If you are not getting a lid open error and the LED strips on both sides of the lid are lit up then it is less likely to be a black lid cable issue. The GF checks for lid to be closed before it checks on the lid camera. You also can fully rule out it being the black lid cable clip that connects to the right LED strip.

In the guide that @eflyguy references has a step to check the cable clips and they give a photo:
Lid Cable Clips

Your issue is likely either the clip connecting to the camera or the one that connects the camera to the LED strip. You can try lifting those 2 connectors and cleaning the contacts if you are comfortable with electronics. There are lots of online resources for cleaning contact points though. But I would focus on those 2 clips.


If you play with those connectors be really, really careful. There have been a number of blown white circuit boards that are likely a result of the connector inserted at a slight angle.


Yes, certainly follow the guides posted from glowforge on how to connect and disconnect those cables.

1 Like

You can see how close the traces are, a slight angle is all that’s needed. Any moisture in the socket is also to be avoided when cleaning.

Google Photos


Oh wow…thank you so much! It does register as lid open and led lights are working. But can’t find camera error popped up

Wow those are close! Is that the one straight to the camera

No, that’s the main connector end, that connects to the small white PCB on the back of the machine under the lid.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.