Server speed

Is anyone having problems with the servers being VERY SLOW tonight or is it just me?

Try clearing your cache and/or using a different browser.


Tried that. Lol

Also ran a speed test on my wifi. (Side note, apple tried to autocorrect wifi to wife but she’s moving fast also if anyones wondering).

1 Like

Everything you do in the design app is local. The only time you’re connecting to the servers is when you upload art, or send a job to print.
The most common issue is the browser getting laggy. Clearing the cache fully will fix that.
2nd most common is WiFi being unstable. The :glowforge: can’t buffer so if the WiFi drops for a split second the :glowforge: has to start the operation again (rather than just buffering like a movie or website does).

If there’s an issue on the :glowforge: end they will update here: - but you’ll see literally hundreds of posts pop up here when there is an issue there.


It was while the design was sent for printing. I’ll do some browser maintenance and see if it doesn’t clear up. Thank you.


I am having the same issue. Everything seems to be lagging on glowforge’s server.

had this issue yesterday afternoon. usually when i drag a file to the GFUI, it would load after only a few secconds. for an hour or so yesterday, it was taking like 5 minutes for the file to appear on the interface. everything was fine on my end (yes, including clear cache). i figure it was the GF servers and eventually it got back to normal.

No issues for :glowforge:, something was up for you locally.

i used my GF from 1 to 5 pm yesterday. it was working fine for a couple of hours and then around 4ish or so, when i was dragging files for cutting (like i had been doing the previous few hours), they would take several minutes to load (the processing message wasn’t appearing). this happened for about an hour and then worked again without my doing anything really – i just waited it out. i should mention that every time i use my GF, i clear my cache before starting. i also know to check my wifi and i did tests and all. so – i don’t think it was anything local on my part. that was the first time it happened, though. so it would be interesting to see if it happens again later this afternoon when i cut orders.

and yet :slight_smile:

WiFi can be affected by many things, including (examples from here) AppleTV, and a neighbor’s microwave! The :glowforge: doesn’t require a fast signal, but it does require a strong one. I’m curious what tests you’re running? I’ve got the WiFi Analyzer app. The staff can check from the back end too, but when the issue is local it’s often fixed before they get to the conversation :slight_smile:

A great strength is -30dBm. At -70dBm or lower would be very difficult to stay firmly connected. I’m lucky in that I’m mostly in the -40dBm range so my connection is fairly robust.

Hi @GFjim. I’m sorry to hear that you ran into some trouble with the Glowforge app lagging as you try to print. I saw @deidrebeth gave some great tips to help check any browser or Wi-Fi network connection issues. If you’re continuing to run into trouble as you try to use the Glowforge app, can you let me know any troubleshooting that has already been completed. I can factor that into any needed troubleshooting to help.

A good test to rule out any specific browser related issues, to try testing the app using another internet browser, or device. It can also help to check if any browser add-ons, plugins, or extensions may be causing any issues as well.

Lastly, it can help to see if you’re noticing consistent lag with all designs, or just specific ones. If you’re only noticing it with some designs, or see it taking longer to render and load, it could be an issue with the complexity and setup of the design. Some complex designs can take more time rendering and adjusting elements in the Workspace. A great resource for optimizing designs in our support page link below:

Let me know if you have any questions, or need any further troubleshooting. I’ll be happy to help. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.