SET FOCUS not working

I find that my “set focus” feature is no longer working as of Feb. 18th 2021. I haven’t used my machine in just over a week, the last time being Feb. 10th 2021 and everything worked just fine with ever single feature.

I get an error saying that “material didn’t measure” and that the material may be to tall or to low. I’ve added two screenshots for the exact verbiage.

When selecting the set focus feature, the printer head will move to exactly where I told it to. It will beam down the little red laser dot, too. All of the lenses are clear, all of the connecting wires are clean and clear of debris.

I’ve read that sometimes an update can cause these issues. Was there an update done between the time I last used it on the 10th and today the 18th?

I can manually set the focus height inside the manual settings to get it to still work, but the auto focus is what has the best results and I want my $4k machine to work as it should since it is only 2 months old.

I also already turned the machine on and off, reset my wifi, restarted my computer, tried different browsers. I am not using a tablet, but an actual laptop computer.


The most likely is that the two little windows on the bottom of the GF laser head are not clean. The red led laser dot comes from one of those windows and is measured to determine material height. A lot of folks don’t know that those windows are there when they clean all the other windows and lens.

I don’t believe that is the case with the two little windows. There is a red dot from the printer head AND I removed the printer head completely to clean every surface and to inspect. There is no dirt, scratches, or smudges that could possibly be hindering the function.

I’ve read other posts from last year where this happened to people and it turned out to be a software issue several times after an update. Not sure if that’s the case though.

Yeah, I don’t remember it ever actually turning out to be a software update issue. How thick is the material you’re using? I can’t tell from the image, is your tray in or out?

My material thickness is 3mm, and the same material I’ve been using since I received my machine in December of 2020. The tray is in, in the picture you are seeing. I tried the set focus feature with the tray in and out and quadruple checked all the measurements, lenses, etc.

Hmmm…any bright lights that aren’t usually there, shining into the bed? Mine is next to a window, and I’ve had to tape fabric over half the top because on sunny days the incoming light messes with its ability to “see” the material properly.

As weird as it sounds, unfortunately, there aren’t any bright lights messing with it. It’s not near a window for that particular problem to occur. I’ve tried doing the set focus on a masked surface, a darker surface, a lighter surface, and so on and so on. I feel like Willy Wonka and his crazy chocolate factory over here with everything I’ve tried by reading up on similar issues through all the forums.

I do appreciate all the suggestions though! keep them coming, you just never know when the smallest thing may just work!

1 Like

I would double check the connection to the printer head and make sure you don’t have any bent pins, a frayed cable, etc. I’d also make sure that the connector is plugged in solidly on the board.

Just going through how it works:

Camera is not seeing the red dot (material not suitable or diode could have gotten moved and is not aligned right, and so on).

The camera isn’t taking a picture.

It’s not transmitting the data back from the camera.


I just did a very deep clean of the whole machine, double-checked the pins. All the pins are very straight and the female end of the cable is free of debris, clean, and nothing is frayed. Still getting the same error, unfortunately.

This was a piece of proof grade walnut with the QR code facing down.

Ohhh, there’s your problem. I’m more and more convinced that deep cleanings are the cause of 80% of Glowforge failures! :wink:

If you enter the material height manually are you able to move forward with the print job?

hahaha, well my version of deep cleaning is just making sure it’s free of the dirt. I don’t go playing with all the electronics and such because I’m terrified of breaking something. Unfortunately, this problem started before that.

1 Like

Yes, I can still print and move forward with jobs if I enter the material height manually.

1 Like

That’s good information! I bet it could help someone who knows more about the inner workings to narrow down the source of the issue. (Unfortunately that’s not me; sorry!)

I do appreciate everyone’s input and suggestions. Just know I do go back and try again and again when suggestions are made, so there isn’t any placation going on. I just want every feature to work on such an expensive machine.

1 Like

I would note that this is probably the third or fourth person I’ve seen with this problem in the last 24-48 hours including people on facebook mentioning it. Have to wonder…

I hadn’t even checked FB for the problem yet. I’ve just seen that people over the last year have had the problem but the solution is always handled through SUPPORT after they dig through the log files for each individual machine.

Hello @ian.m.clark12 - I’m jumpin in to touch base as I’ve recently responded to your email ticket. After reviewing your printer and the nature of it’s trouble, I believe getting a new printer shipped out to you is the best course of action here.

I’ve sent an email along with details on getting that all set up, please keep an eye out for it! Since we’ll be finishing up via email I’m going to go ahead and close topic.

1 Like