Set Focus stopped working after several successful etches

After doing hundreds of the same Chromebook covers, the Set Focus started getting picky about where exactly I set the camera to focus. For the last 50 devices, it would only work if I targeted the bottom-left section of the devices. Now, I cannot get it to work anywhere.

I keep getting the “Error - An error occurred on your Glowforge. Please refresh your browser before printing. It may also help to turn your Glowforge off and then on again.” Once in a while I get a different “Material Didn’t Measure” error that says, “The material was not measured correctly. It may be too short or too tall.” 9 our of 10 times it is the first error.

I tried turning the Glowforge off and on a couple times while also restarting my pc before I turned the forge off to clean the windows and lens of the printer head, the mirror, laser window, and camera lens with the Zeiss lens cleaning wipes. Nothing seemed to help! Boom! Screenshot!

1 Like

I’ve been having similar issues after the latest update. I’ll get these error message or the dreaded ‘centering’ forever issue. Restarts and reconnecting don’t seem to resolve.

Those look to be pretty dark…it might not have enough light to pick up the focusing beam. (And yes, there have been some recent changes to improve focusing that were rolled out and then rolled back in the last upgrade.)

Try sticking a small piece of white masking tape on the macbook (not where you are planning to engrave it) and then using Set Focus on that spot.

See if it works, and let support know if that was the problem.

@MegaMeg, you’ll want to open your own ticket on it by starting a new thread. They count individual tickets with similar problems and use that to prioritize software issues that need to be addressed.

I’d planned on giving it a day or two. Just wanted to pop in and mention that I’d seen the error message as well.

1 Like

They do want to know about problems and they just rolled back an upgrade that was causing some issues for folks, so let them know if you keep seeing it. :slightly_smiling_face:

1 Like

I’m sorry about the frustration when trying to run your prints. I extracted the most recent logs from your unit, and it looks like the top surface of the material may be too close to the printer head for it to accurately measure the material.

Is the material on the crumb tray, or is it being held up using something laser-compatible?

You can print on objects up to 2" thick by removing the crumb tray. However, your Glowforge can’t focus too far down, so you may need to put something laser-compatible underneath your material to lift it up. If you haven’t tried doing this already, raise it until the top surface of your material is between 1.5" and 2" high, measured from the metal plate on the bottom.

Our community has developed some great Tips and Tricks, and this illustrated guide might be just what you need.

Please let us know how it goes!

I’m sorry you’ve run into trouble as well. If you’d like us to take a look for you, we’d be happy to do so! Please start a new thread here on Problems and Support, or you can email us at

This answer would make more sense if the GF threw this error from the beginning.

As was in the original post, the same material/design has been used many, many times just fine. It is just recently that GF is throwing the height error.

This would indicate that the physical height of the top surface is correctly between 1.5" and 2" high.

The material being etched is a chromebook, which in this case is .9" tall, which would make it too tall to etch on top of the crumb tray.

The base being used instead is several sheets of proof-grade draftboard. 7 sheets, which are .125" tall, or .875" tall total.

The base + chromebook is then .875" + .9" = 1.775" tall. Which is right in the middle of the 1.5-2" focus limit.

Would it make more sense to ditch using the auto-focus all together, and instead go back to using the manual focus height settings? This would would get the machine/project back up and running while support continues to look at what’s wrong with the auto focus.

The white masking tape trick that Jules offered did not work, unfortunately, so I can try lowering it. It is being held up by something printable.

Thank you for trying out the masking tape trick. I’ve extracted the log files to review your most recent attempts, and took a look at where the red laser dot is hitting the material. It does appear to be hitting the material at an angle, or not on the exact spot you are attempting to Set Focus on.

I’d like to isolate the material, and see if this occurs on Proofgrade Material with a simple design. Would it be possible to print the Gift of Good Measure on Proofgrade material, while also utilizing Set Focus?

Also, I’d like to take a look at an image of the bottom of your Printer Head. Could you send over a photo similar to the one below?:

Once we can review the results of the test, and the image of the bottom of your Printer Head, we’ll send over the next best steps. Thank you!

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email and share the results of the test, as well as the photo requested in Marc’s previous comment. Thank you!