Set focus suddenly not working on Chrome MacOS

Hi there!

Midway through a job today (Thursday Apr 23, 0822 CST) suddenly my set focus would not work. I would choose set focus the first time and nothing happened, and the second time it would focus wherever it had focused once before but no movement to where I wanted it, no tiny red focus square.

Here’s my browser info:

I tried rebooting the app, rebooting the Glowforge, rebooting the computer, and none of those helped. So then I tried it on Safari and that worked. Something goofy with Chrome I guess. Why it decided to fail halfway through a job is a mystery to me.

Update: Once I got it working in Safari, it was working in Chrome for me. It might all be a figment of my imagination.


Probably not a figment of your imagination. Hopefully they’ll get it sorted quickly.

I’m so sorry for the trouble.

Thanks for letting us know.

I’m glad it seems to be resolved, but I’ve opened an investigation to see if we can figure out what happened.

If you see the same thing again, please open a new post. A short video of what you’re seeing might be helpful as well.

I’m going to close this thread for now.