Set Focus woes (AGAIN!)

OK so we are back at the failing set focus issues again. OK so setting focus is failing 100% of the time again with the most unhelpful error message:

(that is the equivalent of the “does not compute” that Rodney the robot on lost in space used to say). If it’s a network issue tell me, if it’s a camera blurry issue tell me, electrical, whatever…

Anyway, so last time you folks thought it might be wifi. My problem with that is that A) my wifi seems to be working great if I place a laptop on top of my GF I get very fast connectivity (80+mbit symmetric) and B) that doesn’t explain why everything else on my machine works like a champ, So homing, no problem, refresh bed image, no problem, running a job, no problem. So either set focus is particularly wifi sensitive in some way compared to everything else the machine does, or there is something else going on here. I know yesterday there was some network funkiness on the internet so tried again this morning and same result. I’m going to try rebooting the machine to see if that helps?

And BTW: if wifi is this often a problem for you guys, add a diagnostics function under the … menu. Like do a wifi test to the cloud. (not just total pass/fail, but speed and whatever other things cause issues for the machine).


They will be along, but just to say the GF must have a 2.4 Ghz Wi-Fi signal and it must be fairly strong with no interment connections and other devices can have an effect on that signal.

I get that. My point was it only affects set-focus not all the other functions of the GF. And again if their machine requires such a twitchy network stack that can’t handle latency or dropped packets, they should have added ethernet (not to flog that dead horse) capability. Because blessedly my Tormach, Prusas, Form 3 and X-carve all use ethernet and the networking is never an issue (normally my failed thinking causes the issue)

1 Like

Oh no, I’m sorry you’ve hit a snag!

I’ve extracted your machine logs to review your most recent print logs.

It appears that your Autofocuser is having a difficult time measuring your material and this may be due to the material you’re printing on. For example your recent print of “Inground lift label” is a very reflective material. When compared to your recent print on Proofgrade, the results are extremely different.

Can you tell me a little bit more about the material you’re printing on?

It is a slab of Paduk with masking paper on top (so should be identical reflection wise to proofgrade.

I have had this several times and have just ignored it. The most recent project where it came up was PVA foam. I just continued with my project and everything worked out. I don’t know if that is an option for you.

Again, no because of the 3D engrave. It ultimately just worked for whatever reasons (focus gods were no longer angry?)

Unlikely this is the issue but…

What’s the lighting like above the machine? I have a sheet of rough abs that can’t be focused on between the hours of 11:45AM - 1:15PM.

I use a piece of white 1/4” PVC sheet on top of the lid. On sunny days.

while this sounds like a scene from Zork, It is a windowless room in the basement. LED lighting on the ceiling.

1 Like

Thank you so much for providing that additional information. I apologize for the misunderstanding on my end. After investigating further, it looks like the trouble is appearing because the Glowforge is having trouble communicating with the printer head. There are two key connections I’d like you to check for me.

Could you please do the following?

  1. Turn off your Glowforge.
  2. Holding only the finished black surfaces, grasp the printer head as shown. Pull gently up and back to disengage the magnets and remove the head.
  3. There is a small tab in the center of the wire ribbon. Push down fully on the tab to release it, and gently pull the wire ribbon plug from the printer head.
  4. Take a clear photo of the gold pins inside the printer head where you just unplugged the wire ribbon. It should look like this.
  5. Pick up the printer head and wire ribbon. Make sure the tab on the wire ribbon is facing up. Slide the ribbon back into the head until it clicks.
  6. As shown, lower the printer head over the metal plate so that it rests next to the two round posts. Then push it gently away from you – you’ll feel a “click” as magnets pull the printer head until it sits snugly atop the metal plate.
  7. Pull the laser arm all the way forward.
  8. Reach over the laser arm, and to the left of the inside of the unit and you’ll see this circuit board:
  9. Take a photo of the circuit board. If the cable I’ve indicated above with the red arrow appears to be loose, please reconnect it and try printing again. This cable should ‘click’ back into place.
  10. Turn your Glowforge back on.
  11. Send us the photos you took in step 4 and step 9.

OK, I will take a look today if I get a chance

I’ll get get the pins (and as for the board, it’s the maid’s day off…)

You are likely to be eaten by a Glowforge.

>focus camera

You used the word “focus” in a way I don’t understand.


Thank you for taking the time to work through those steps, and for sending over these images. Based on the photos, everything appears to be connected correctly, and I’m not noticing any snags with the pins on the Printer Head.

I’ve extracted the log files from your Glowforge to review your most recent prints, and it looks like the most recent print that was completed successfully was around December 18th. During this print, Set Focus was used, and it appears to have been completed successfully. That’s great! However, I’d like to make sure we have a more recent print to review to make sure nothing else is running into trouble.

Could you perform a print where you originally noticed the error, and see if the same behavior occurs?

Let us know how it goes!

It’s been a while since we’ve heard from you, so I’m going to close this post.

If you are still having trouble, please start a new post or email us at