Set up Problems - Not so easy as you all say

When I get to the step Sign In and Connect Your Glowforge to Wi-Fi. I just run into and endless circle of clinking the same link and going to the same pages over and over again. I’ve gone to and signed in clicked on the setup link(again) I connected to the glowforge and nothing happened. I pushed the teal button (probably a dumb idea, but nothing else was happening) and nothing happened and now the button isn’t glowing anymore.

“Follow the instructions on screen to connect to your Glowforge unit’s Wi-Fi. You will not be able to access the internet again until you either finish, or stop and reconnect to your usual Wi-Fi network.”

What on “screen instructions” are you talking about? Is something supposed to pop up or just read along and hope something happens? I connected to the glowforge via it’s wifi and then nothing happens. And now the glowforge doesn’t even show up in my connections for wifi.

WTF? Easy setup my ass. What do I do now? Turn it off and try to start the endless cycle of instructions and hope it works?

I’m not sure because I don’t have it in front of me any more, but there is a step where you have to click Continue before you switch to the GF network, and it doesn’t say to do that anywhere, so it’s confusing.

Might try that and see if it helps.

1 Like

OMG!! Talk about being a little slow(me, mentally that is) I guess this was my bad and connected to the glowforge first before pressing the continue button.

They should make that step a little clearer.

1 Like

Well, that might not be it…try it and see. :slightly_smiling_face:

I went through tons of frustration and forum searching for what might be the same problem. There is a missing step in the setup instructions.

I was following on my PC. I got to the part where I put my phone in airplane mode and connect to my GF WiFi. I saw it listed and connected, but no setup instructions on my phone appeared.

Then I saw that someone was connecting to I did that on my PC. No luck.

I tried on my phone. No connection b/c I was connected to my GF.

I then disconnected my phone from GF WiFi. Connected to my home network. Went to Then it magically said it found my GF and told it to broadcast WiFi. I again switched to GF WiFi and now setup proceeded properly.

I’m guessing that the expectation is that one is running through on the same device as will later connect to GF WiFi. Where does it say that in the instructions?

Thanks all for your help. I’m glad/sad to see I’m not the only one who got a little lost.

1 Like

Did you get it connected?

The setup instructions are not the best part of the product.

You are not the only one who has found it frustrating to follow the directions or even find the directions. Because the instructions are included as part of the procedure to setup the machine, if something goes wrong, the sequence gets lost.

Having two devices is good or printing the manual section with setup instructions is also good. I use a mobile device to do the ad hoc connection handoff and keep my desktop on waiting for the Glowforge to appear.


They tried to make that part a little too magical…but magic is hard!

1 Like

My desktop was still on where it told me to connect to my GF wifi. I don’t recall being told in that flow to go to Maybe I missed it. :astonished: I’m thinking that the device on app.glowforge has to be the one that then connects to GF wifi to setup your home wifi credentials.

Maybe @Rita can clarify.

The URL for setup has changed over time. The URL on the label currently shipping says but used to be (without the “/setup”) is for normal operations after the wifi is completed.

1 Like

My insert said “”. I think that the issue is that the device connected to should be the same device that will connect to the GF wifi to setup home network credentials.

I used my iphone to connect to GF wifi while my PC was connected to setup. I thought this would help because I could follow instructions on the PC while my phone was disconnected from the Internet.

A simple note about this would’ve saved me a lot of time. :smiley:


Thank you all for letting us know about this! I’m glad you resolved it.

I’m going to make sure the team receives this feedback.