Setup -> Calibrating -> Offline Cycle


#1

My Glowforge had been stable forever but recently I have non-stop connectivity problems. I have spent far more time debugging recently than actually getting prints done.

I have been through the setup cycle over and over. It will say I am connected, then go to calibrating, then go to offline. Sometimes it cycles back to calibrating for a while. By doing this enough times we have managed to get a couple of prints done in the last day but mostly its just a lot of wasted time. Now it’s 12:45 AM and mother’s day projects are not going to happen…

I have tried cycling my router, changing my wifi channels, using 2.4ghz, 5ghz. All the combos, going through setup again each time. I have no problem connecting with MacOS, iOS, or Android. I am using a wifi signal monitor and trying to use optimized channels - seeing a signal at ~-51db from the WAP which is ~15ft away (through a floor).

The decision to ship a ‘pro’ tool with no ethernet port continues to baffle me. I would just like a device with the connectivity options and stability of a raspberry pi.


#2

15 feet through a floor can be a very long way if it is through the wrong material. Pick up a Wi-Fi Wall Plug Range Extender / Repeater for $20 and know for sure that’s not the problem.


#3

It and the WAP were in the same locations they had been stable in for months.

  • Every other device I have tried connects just fine from the same location
  • When I go through setup it sees the network and connects just fine.
  • I have now tried moving it directly under the router where wifi analyzer shows -40db signal. Same issues.

Immediately after setup it just seems to go offline now. I have no way to tell if the issue is wifi or possibly something else - I’m just guessing.


#4

Did you try cycling your router? (Unplug it, wait a minute, plug back in.)


#5

I’ve restarted the WAP and the router probably 15-20 times in the debugging process.

I am seeing high latencies on my 2.4ghz network. My running theory is that the GF relies on web sockets and these are unstable but not quite unstable enough to seem like complete failure.

My 5ghz network is seeing consistent 6ms latency but unfortunately does not help.


#6

That unfortunately sounds like so much Greek to me…I do know the GF uses 2.4ghz though. I think. :smile:

If you have a smart connect that’s scanning for whichever is open, you might need to turn that off.


#7

The latency sounds like the router may be going. It’s either that or the Wireless section of the GF. I’m sure one of your friends has an older router laying around he upgraded from; maybe before dual-band was a big thing. I initially wrote and just erased a suggestion you could easily configure the spare router as a WAP. Doing so wouldn’t prove your current router was good or bad however, because once the signal makes it through the WAP it is running through the same router. Best to replace yours with the spare, just long enough to see if it cures your GF problems.


#8

The latency appears to be noise/congestion from the increasing number of devices on the 2.4ghz network. The router itself is a solid state device which will not generally degrade over time - its more likely to just fail outright. Degradation is normally due to software or environmental (my case I think) changes.

I appear to have resolved this for the time being by digging out an old router and setting up a new 2.4ghz network in the garage by the GF. This is using wired backhaul, not wireless repeating. It is possible I could use 5ghz backhaul but using a repeater on my existing 2.4ghz network would not help.

It’s important to note that this does not appear to be a signal strength issue. It’s a matter of high latency and packet loss on the network. While this is more likely on a congested wireless network it could occur on a wired network as well. Unfortunately, my 2.4ghz network is home to all my cheap or old devices … and the glowforge.

GF should really be more resilient to these conditions. As I mentioned above, my suspicion is that they are dependent on a websocket which really ought to degrade to HTTP polling in poor/intermittent network connections. At the very least this could be used to post a status to GF saying the network is problematic and how. I am guessing here but the symptoms are similar to how other websocket based apps (Slack…) work (or don’t work) in poor network conditions. Other apps/devices exhibit poor performance on the same network but do generally function.

Besides the lack of an ethernet port the most disappointing thing here is that the GF does very little to help you debug. This is especially disconcerting when it had been working for months and suddenly stops. I am now suspicious that the times calibration took extra long were just network issues in disguise.

My specific feature request from this would be to use button colors for specific startup phases and then flash that color if it is stuck on that phase. The useful phases would be something like Booting -> Connecting WiFi -> Connecting to GFHQ -> Calibrating -> Ready (lights out).


#9

I’m glad you resolved it!

Websocket falling back to HTTP polling and additional button color indicators are great ideas for features - thanks for the suggestions! I’m going to send them to our product team with a note that they came from a customer request.

I’m going to close this thread - if the problem reoccurs, go ahead and post a new topic. Thanks for letting us know about this!


#10