Shape in vector file won't print?

I have a .svg with this shape:

The border is hairline thin, both blacks are 000000. It reads into GF software just fine.


When it rasters, I only get the “0” but not the “5”. It cuts out fine.

I’m trying to salvage what’s there, so I upload a file with just the 5 and realign everything. When I run this second cut (pic below) the laser doesn’t fire at all.


What is wrong with the 5? I don’t think I did anything differently to it, but it does not engrave.

In addition, in the print preview, nothing shows. Usually there is red fill showing you where the laser would engrave. Therefore I think it is a software/file issue.

it would help if you could upload the SVG for us to look at. there are a few things that could cause that. including having a second copy of the 5 stacked on top.


Ah, the second copy I think is the cuplrit. I made the file a long time ago and usually never need to check it (for the other lasercutters I used, it just went off of the color of revealed layers instead of digging into hidden layers/engraving white shapes.) Thanks!


But… if there were truly just 2, wouldn’t it just do 2 passes on the 5 then instead of ignoring it?

i can’t explain why, but two objects directly on top of each other in the same color cancel each other out. it’s definitely a known issue.


I think I jus figured out the cause of my issue and yours. I do think it’s a software bug with the new update.

1 Like

I haven’t tested to be honest (because I don’t set my files up that way), but I don’t believe the colors even matter. I could be wrong though. I believe if they are in the same actual job, it will knock out the overlap area. Running them as separate jobs (ie run the first one, then ignore first one and run second one) will make them overlap.

yes, this is true. and maybe sometimes desired (i can think of some scenarios). but it’s also useful for when you’re doing similar designs on both sides of a piece of material. there are other ways to make that work, but it’s still doable that way.

i still think of this as a bug, though. it’s not exactly the behavior you would expect from doing this.

I think they treat it like a clipping mask and just ignore both. Haven’t tried 3 copies to see if it ignores 2 of them and leave the third but I expect they’re all ignored.

i think that’s effectively what’s happening. but it’s not intuitive and it would be nice if they could figure out how to read that differently.

Interestingly, this is the same kind of thing you need to do to get even-odd vs. nonzero winding rules right…


i haven’t tried seeing how this works in PDFs. there are things that work in PDF that don’t work in SVG, that would be a good test.

1 Like

For future reference, the 2 5s were the same color. One was on a layer underneath. I never bothered to hide it or delete it since my previous pipelines just engraves what you see, doesn’t snoop around the other layers. (.ai --> .svg --> coreldraw --> universal, and .ai --> epilog)

I keep finding other bugs/problems, will try to bring my original thread up! I am still unable to find the quality of rasters I used to have :confused:

Layers don’t matter

1 Like

Thanks for letting us know about this, and I’m sorry for the trouble. It sounds like you were able to get the file to print correctly, but I’d like to offer some more information. Your Glowforge won’t print overlapping filled vector shapes, which I believe is the issue. If you run into this again, I’d suggest removing one of the copies, or combining them before trying the print again.

I’ll close this thread now, but if you run into any other trouble please let us know.